• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

cache not rebuilding automaticaly?

#1
search has been working fine, but had user report thread posted 3 days ago not appearing in search. sure enough I couldn't get the thread back in results. I manually rebuilt the cache and then it came up. isn't there an automatic process to keep search results updated? thanks.
 

Brogan

XenForo moderator
Staff member
#2
The search index is automatically populated/updated when content is created/edited.

If this is not happening, it could be due to a third party add-on interfering with the process.
The fact that a manual rebuild works suggest that the service is running and working so it's just indexing which is failing.
 

Andy.N

Well-known member
#3
search has been working fine, but had user report thread posted 3 days ago not appearing in search. sure enough I couldn't get the thread back in results. I manually rebuilt the cache and then it came up. isn't there an automatic process to keep search results updated? thanks.
I have the same experience that latest posts are not shown up when clicking on that member's activity link. Disabled all addons except XFES and the problem remains. Would be interested in your findings.
 

Jake B.

Well-known member
#5
The search index is automatically populated/updated when content is created/edited.

If this is not happening, it could be due to a third party add-on interfering with the process.
The fact that a manual rebuild works suggest that the service is running and working so it's just indexing which is failing.
I've disabled all add-ons other than XFES and it's still happening

RobFerrari is possibly not clarifying that his bug is specific to search filtered by 'Member' results as detailed here;

https://xenforo.com/community/threads/stale-search-index-and-cache.136775/post-1189981
From my tests that doesn't seem to be the case, it's happening with a "normal" keyword search as well

Edit: Ended up fixing it by switching off "Enable single type mode in Elasticsearch"