1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 bunch of 'max_user_connections' errors after upgrade to 1.2.3

Discussion in 'Troubleshooting and Problems' started by electrogypsy, Nov 6, 2013.

  1. electrogypsy

    electrogypsy Active Member

    i upgraded XF from 1.2.2 to 1.2.3 today, but unfortunately my internet got disconnected half way through the upgrade. i resumed it, but ever since the upgrade was completed i've been getting a lot of messages like so:

    Code:
    An exception occurred: User db**** already has more than 'max_user_connections' active connections in ****/html/community/library/Zend/Db/Adapter/Mysqli.php on line 333
    
        Zend_Db_Adapter_Mysqli->_connect() in Zend/Db/Adapter/Abstract.php at line 315
        Zend_Db_Adapter_Abstract->getConnection() in XenForo/Application.php at line 684
        XenForo_Application->loadDb()
        call_user_func_array() in XenForo/Application.php at line 921
        XenForo_Application->lazyLoad() in XenForo/Application.php at line 952
        XenForo_Application::get() in XenForo/Application.php at line 1336
        XenForo_Application::getDb() in XenForo/Error.php at line 52
        XenForo_Error::unexpectedException() in XenForo/Application.php at line 363
        XenForo_Application::handleException()
    i talked to my hosting company (mediatemple) and nothing has been changed over there, so im assuming something got screwed up in the upgrade. obviously 'max_user_connections' means i have too many scripts running to the mysql database (max is 30), but im not sure how to track down the problem.
     
    Last edited: Nov 6, 2013
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    Do you have an abnormally high amount of users hitting your site today?
     
  3. electrogypsy

    electrogypsy Active Member

    a slight bump, to about 40 people online at any time instead of the average of 25-35.
     
  4. Mike

    Mike XenForo Developer Staff Member

    There's really nothing in (or since) the upgrade that should cause that. If it happens, you'd need to (quickly) run the following query via something like phpMyAdmin:
    To try to figure out if there are a bunch of lingering connections.

    You could disable the "Enable Delayed Insert SQL Queries" option as well.
     
  5. electrogypsy

    electrogypsy Active Member

    i think i just got an unusual bump in traffic due to a local news article at unfortunately the same time i was upgrading the forums (or shortly before/after). i've been looking into it and it seems like this isn't a XF issue. thank you for your responses though!
     
  6. DFI

    DFI Active Member

    Even my website is facing similar issue. Tried above but issue remains the same.

    Is other Xenforo forums are having similar issues ?
     
  7. SelfSufficientMe

    SelfSufficientMe Well-Known Member

    Yeah, I get the same sometimes after I Tweet a page but not every time - I guess it causes more activity suddenly. This probably happens to me once a month or so but my host has no idea and just suggested to upgrade to a dedicated server or VPS. For now, I'm just ignoring it. I haven't upgraded to 1.2.3 as yet - will be soon - so it probably isn't related to the new upgrade (that's just a guess).
     
  8. DFI

    DFI Active Member

    Same with me too. I have recieved a email from my host suggesting to go for a dedicated server.

    Something surely not good with 1.2.3 . I am getting traffic from foreign counmtries which is not required as my forum content are not international.
     
  9. MotMann

    MotMann Active Member

    The same Problem on all my Forums since update

    User xxxxx already has more than 'max_user_connections' active connections - library/Zend/Db/Adapter/Mysqli.php:333

    #0 /www/htdocs/xxxxxx/library/Zend/Db/Adapter/Abstract.php(315): Zend_Db_Adapter_Mysqli->_connect()
    #1 /www/htdocs/xxxxxx/library/XenForo/Application.php(684): Zend_Db_Adapter_Abstract->getConnection()
    #2 [internal function]: XenForo_Application->loadDb(Object(Zend_Config))
    #3 /www/htdocs/xxxxxx/library/XenForo/Application.php(921): call_user_func_array(Array, Array)
    #4 /www/htdocs/xxxxxx/library/XenForo/Application.php(952): XenForo_Application->lazyLoad('db', NULL)
    #5 /www/htdocs/xxxxxx/library/XenForo/Application.php(1336): XenForo_Application::get('db')
    #6 /www/htdocs/xxxxxx/library/XenForo/Model.php(161): XenForo_Application::getDb()
    #7 /www/htdocs/xxxxxx/library/XenForo/Model/DataRegistry.php(138): XenForo_Model->_getDb()
    #8 /www/htdocs/xxxxxx/library/XenForo/Model/DataRegistry.php(97): XenForo_Model_DataRegistry->_getMultiFromDb(Array)
    #9 /www/htdocs/xxxxxx/library/XenForo/Dependencies/Abstract.php(144): XenForo_Model_DataRegistry->getMulti(Array)
    #10 /www/htdocs/xxxxxx/library/XenForo/FrontController.php(127): XenForo_Dependencies_Abstract->preLoadData()
    #11 /www/htdocs/xxxxxx/index.php(13): XenForo_FrontController->run()
    #12 {main}

    My hoster means, that the scripts are missing the "close" for the database. What shell i doing?
     
    Last edited: Dec 7, 2013
  10. au lait

    au lait Well-Known Member

    We have the same problem. Are also at all-inkl.com
     
  11. HWS

    HWS Well-Known Member

    You should disable "Delayed Insert SQL Queries" in your XF options.
     

Share This Page