1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Broken Left Pagination Arrow

Discussion in 'Styling and Customization Questions' started by Amaury, Feb 27, 2014.

  1. Amaury

    Amaury Well-Known Member

    As title.

    I can't figure out what the problem is, but it's not an issue on the default style, so it's something to do with our custom style, but oddly enough, it's not an issue on the styles I have released on here, only this specific style (KH-Flare 4.0). However, it's also an issue on here, another forum I'm a member of, so I must have done something the same as them that made it break.

    Pagination.png
     
  2. Amaury

    Amaury Well-Known Member

    I forgot to mention that what's odd is that @mistypants said she doesn't see the issue on either KH-V or KH-F, so I'm not exactly sure what the problem is.
     
  3. Amaury

    Amaury Well-Known Member

    Any ideas?

    Inspecting the CSS, I don't really see anything different between Default Style and KH-Flare 4.0. Here's a section with lots of threads. Go to about page five to get the left pagination arrow to appear.

    KH-Flare 4.0 is disabled to the public, so if you need to be able to view it, just create an account and I can give you temporary access to the administrator control panel.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Is the style publicly available?

    If not, it won't be possible to debug.
     
  5. Russ

    Russ Well-Known Member

    Page nav is very picky, I've learned to avoid editing in certain ways :D.

    Adjusting the width should only be done via the property on the settings page of the page nav area:

    PageNav Link Width

    For heights, I usually do padding top and bottom inside PageNav Item, then you'll need to make some manual CSS adjustments for the middle section(use inspector).
     
  6. Amaury

    Amaury Well-Known Member

    I've temporarily made it available.
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Remove the bold tags from the arrow.

    upload_2014-3-6_19-21-14.png
     
    Amaury likes this.
  8. Amaury

    Amaury Well-Known Member

    Just for the reference, I don't have any custom CSS relating to pagination.

    Where are you seeing this? I'm inspecting the elements, but I'm not seeing any font-weight: bold. Am I inspecting the wrong element? I've tried the arrow and the whole container (PageNavPrev), but I'm not seeing anything bold. I'm not seeing anything bold in the pagination style properties, either.
     
  9. Russ

    Russ Well-Known Member

    XenForo has that arrow wrapped in a <b> tag, it's probably another issue resulting in it.

    Have you tried reverting your page nav style properties to work backwards in a sense.
     
  10. Amaury

    Amaury Well-Known Member

    I found the problem. It was the PageNav Container style property. I had customized the font size to 12px and reverting it to the default 11px fixed it. Although I'm not sure why that would have caused the problem.
     
  11. Russ

    Russ Well-Known Member

    If you're going to adjust the font you usually need to adjust the heights/widths of it, as some of it is set to overflow hidden.
     
  12. Amaury

    Amaury Well-Known Member

    Are you referring to this in the additional CSS box?

    Code:
    line-height: 16px;
    I tried adjusting that to no avail, and I also tried adding a height in that height box that's blank by default to no avail. I can live with 11px, though.
     
  13. Brogan

    Brogan XenForo Moderator Staff Member

    Adjusting the width is probably more relevant.
     
    Amaury likes this.
  14. Amaury

    Amaury Well-Known Member

    I've tried adding width to the width box and inspecting the CSS and manipulating this CSS to no avail:

    Code:
    a.PageNavNext {
      color: #FFF;
      background-color: transparent;
      padding: 1px;
      border: 1px none #000;
      cursor: pointer;
      width: 19px !important;
    }
     

Share This Page