1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Board URL in options not changing to https

Discussion in 'XenForo Questions and Support' started by ix2013, Sep 1, 2013.

  1. ix2013

    ix2013 Member

    I changed my Board URL in /admin.php?options/list/basicBoard from http to https but it still hasn't changed on my site. I've cleared cookies and cache and tried other browsers but the source still shows http.
  2. Chris D

    Chris D XenForo Developer Staff Member

    You need to ensure your webserver is configured to accept connections to https and also redirect http connections to https.

    This isn't done by simply changing the Board URL. This is very much a server configuration thing so I would suggest speaking to your host for assistance with this.
  3. The Forum Heroes

    The Forum Heroes Well-Known Member

    Force it to SSL using Apache re-write in .htaccess
  4. Brogan

    Brogan XenForo Moderator Staff Member

  5. ix2013

    ix2013 Member

    Followed that and now it says in the address bar it's verified and encrypted, but the site isn't displaying.

    Firefox error: The page isn't redirecting properly : This problem can sometimes be caused by disabling or refusing to accept cookies.

    Chrome error: This webpage has a redirect loop : The webpage has resulted in too many redirects.
  6. ix2013

    ix2013 Member

    I should mention that I'm using Cloudflare's Flexible SSL feature. According to them, all I needed to do is get my website to use https.
  7. The Forum Heroes

    The Forum Heroes Well-Known Member

    Did you still install a certificate for your domain? Using the Cloudflare Flexible SSL, it can be self signed as it won't be used, but it's still required for Apache to use port 443.
  8. ix2013

    ix2013 Member

    I can't install a certificate myself as that's only with a Business or Enterprise plan. With Flexible SSL, I shouldn't need to though. Port 443 is open.
  9. The Forum Heroes

    The Forum Heroes Well-Known Member

    But there is no httpd conf setting for your domain for 443, that is why your getting the looping error. That's why you need to use at least a self signed certificate.

Share This Page