• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Board URL doesn't update on forums?

RastaLulz

Well-known member
#1
When I change my "Board URL" under "Basic Board Information" in the "Options" section of XenForo, it doesn't seem to update on the forums. It is saved in the field (i.e. if I reload the page, it's saved). Is the board URL cached somewhere, or something?
 

Brogan

XenForo moderator
Staff member
#2
Where is it not updating?

The board URL in the ACP is generally used for the logo link and links in emails, etc.
 

RastaLulz

Well-known member
#3
Where is it not updating?

The board URL in the ACP is generally used for the logo link and links in emails, etc.
The only place it seems to update is in the actual field under "Basic Board Information".

It doesn't seem to update on the actual forums, meaning the CSS paths, JavaScript paths, site links, etc. are still using the old the board URL.
 

Brogan

XenForo moderator
Staff member
#4
The image path is set per style in Style Properties -> General

Do you use any form of caching? Cloudflare or similar?
 

RastaLulz

Well-known member
#5
The image path is set per style in Style Properties -> General

Do you use any form of caching? Cloudflare or similar?
I do use CloudFlare for caching, but I don't see why it would affect the HTML it self where the pages are dynamic. Regardless, I have it on "Development Mode", so it shouldn't be caching any thing right now. Other than that, no I do not use any other form of caching, which is why it's odd to me. I've even tried rebooting my dedicated server to see if that would change anything, to no result.
 

Brogan

XenForo moderator
Staff member
#10
I'm still not clear on what is not updating.

Changing the board URL in the ACP isn't going to change your domain and where your site is installed.
 

Tracy Perry

Well-known member
#11
Sure. I'm trying to update my site to use SSL (via CloudFlare), so I have updated my board URL from "http://devbest.com" to "https://devbest.com", but it's still using "http://devbest.com". I've even tried changing it to "http://example.com", to no result.
You've also got a problem that if anyone prefixes your domain with www, they are getting a page not found error. Another thing you need to do is do a rewrite in your server config to fix that issue (but it's a minor one).
Do you by chance have anything in your .htaccess (or nginx vhost config if using nginx) that remaps requests to http://?
Do you have https enabled in your web server configuration and pointing at the location for your site?

To expand on what @Brogan said, to change the domain (and https/http) is handled in your web server configuration (again, depending on what you use either an nginx vhost configuration, an apache2 vhost configuration or set up as your default in your apache2 config file). The URL you are pointing to has nothing to do with what is actually being served to the requesting browser (other than the logo URL, etc - which is still not directly involved).
 
Last edited:

RastaLulz

Well-known member
#12
I'm sorry, I was under the impression that if I were to change the board URL to anything it would link me to that site, instead of using my current URL. For example if I clicked the logo after refreshing, it'd take me to "example.com".
 

Tracy Perry

Well-known member
#13
I'm sorry, I was under the impression that if I were to change the board URL to anything it would link me to that site, instead of using my current URL. For example if I clicked the logo after refreshing, it'd take me to "example.com".
That will... BUT - that domain has to be being served (whether it is via http or https) via the web server configuration and that is controlled by the Home Page URL in the Basic Board settings area - and the Link Logo to Home Page URL has to be checked..
What you are changing mainly impacts the email that is sent on thread watches, approvals, etc, but has nothing to do with what the domain is being served on. Again, that is entirely configured (the serving of the domain) by the web server configuration.
 

Tracy Perry

Well-known member
#15
I've also forced all HTTP traffic to HTTPS, as Brogan's link above suggested. http://d.pr/i/zX2c
Is your webserver LiteSpeed?
Also, your re-write is not taking, as when I go to the http site, it does NOT redirect me to a secure https connection. When going directly to https it does not process the CSS.
Are you on a shared host, VPS or dedicated server? Have you restarted the web server?
 

RastaLulz

Well-known member
#16
Is your webserver LiteSpeed?
Also, your re-write is not taking, as when I go to the http site, it does NOT redirect me to a secure https connection. When going directly to https it does not process the CSS.
Are you on a shared host, VPS or dedicated server? Have you restarted the web server?
  1. My webserver is Apache, using WHM.
  2. I disabled the redirect due to it breaking my site. When you went to the CSS files, it would redirect - but it'd start off by going through http.
  3. It's a dedicated server. I have not tried restarting the web server recently.