• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

beta 4 - Upgrade issue : This action is available via POST only.

Andy.N

Well-known member
#1
When I go to /install/ to upgrade, it will show the button to Begin upgrade, when I click on it, it will show a log in box again.
Enter the info and it will show this error "This action is available via POST only. Please press the back button and try again."
 

Deebs

Well-known member
#2
Andy,

Are you running a cache for variables? I had a similar issue which was due to have APC enabled in the config but disabled in the php config. Wouldn't let me login until either I enabled it in PHP or disabled it in library/config.php as the session was not being stored anywhere.

Could be something similar for you?
 
F

Floris

Guest
#3
I fixed this by increasing my APC cache size to 128 and restarting apache, and running install/ again.
 

Mike

XenForo developer
Staff member
#5
If you're running a cache that can't potentially fit more (APC being a good example), then you should increase the size. We've made the next release explicitly opt-in to pulling the sessions from the cache for this reason. (Not to mention with APC, you may see your webserver being restarted for log rotation or similar work, which will wipe out sessions.)
 

Andy.N

Well-known member
#6
Andy,

Are you running a cache for variables? I had a similar issue which was due to have APC enabled in the config but disabled in the php config. Wouldn't let me login until either I enabled it in PHP or disabled it in library/config.php as the session was not being stored anywhere.

Could be something similar for you?
Yeap.
I have APC enabled on my config.
Disable it and was able to start the upgrade.

Upgrade done. Case solved. Thanks Deebs
 

Andy.N

Well-known member
#7
I spoke a bit soon.
The ACP login does not log me in after I enabled APC again in the config file. I guess I need to increase the size of it?

I fixed this by increasing my APC cache size to 128 and restarting apache, and running install/ again.
I believe I have 128MB. Where do I increase them again?
 
F

Floris

Guest
#8
On my setup the phpinfo shows me which php.ini I used, whre the config variables usually are. However, on my ubuntu setup for some reason the apc.ini was within conf.d/
 

Mike

XenForo developer
Staff member
#10
This is roughly only an issue if you're using APC's user cache (via explicit configuration in config.php) but don't actually have enough space to keep storing user cache entries. In reality, in that situation, you're probably just causing more problems for yourself anyway.

It won't affect many people.
 

Andy.N

Well-known member
#11
On my setup the phpinfo shows me which php.ini I used, whre the config variables usually are. However, on my ubuntu setup for some reason the apc.ini was within conf.d/
Where in the ACP which we can view phpinfo again? I know there is a link but it's not exposed anywhere is it?
 
F

Floris

Guest
#13
admin.php?tools&phpmyinfo i think .. don't quite remember.

cli:

cd

locate apc.php

then cp that/location/apc.php public_html/apc.php

and you can load it in the browser, set a user/pass within apc.php to load the user cache, upon success it will have prefix_session_garbledstuff
 

Andy.N

Well-known member
#16
Andy,

Are you running a cache for variables? I had a similar issue which was due to have APC enabled in the config but disabled in the php config. Wouldn't let me login until either I enabled it in PHP or disabled it in library/config.php as the session was not being stored anywhere.

Could be something similar for you?
Yuck.

look at the phpinfo and apc.shm_size = 30

I always thought I had it at 128MB.

Deebs,
You were on my server before. I'm trying to locate apc.php and increase it to 128MB.
 

Deebs

Well-known member
#17
Yuck.

look at the phpinfo and apc.shm_size = 30

I always thought I had it at 128MB.

Deebs,
You were on my server before. I'm trying to locate apc.php and increase it to 128MB.
Send me the details again in a PC and I will login and fix.