BBcode MediaSites Package [Deleted]

Rho Delta

Well-known member
I still have
BBcode MediaSites Pack 1.0.0
Is that an older version of this add on or is it by someone else?
 

EQnoble

Well-known member
do we update like any other addon or do we need to delete media sites first?
I wouldn't say go and delete mediasites only because many people I assume who use this addon have also added bbcodes which use MediaSites as a directory for their callbacks.


You should be able to just upload the entire contents of the UPLOAD folder to the forum root and overwrite all the files in the MediaSites directory and then just upgrade the addon via the xml.

I still have
BBcode MediaSites Pack 1.0.0
Is that an older version of this add on or is it by someone else?

I believe that was a version I put together before the RM was available for use. All of the bbcodes in this pack that I didn't make myself were posted in a community mediasite thread. Short answer: it is the same addon.

The addon title is still BBcode MediaSites Pack, the archive name I used allows me to keep things listed on my computer here in order of versions. It is just that now I use AddonID+Version string to name the zip files...( this update being media_sites_package + 1000531 which I named media_sites_package_1.0.5_31 so I can identify the version quicker in my storage here)

Since 1.0.0 I have updated every bbcode at one point or another to keep up with sites that change their back-end up and/or more than likely their embed methods. Sometimes the embed is the same but the urls to the site pages change so while embeds already posted work , new ones wont be caught in the expressions. Some sites become unstable or their embedding features are removed and so on and so on and every one of these seems to be a little bit different at the very least

At any rate you should just be able to upgrade from that version to this one after uploading all requirements in the new zip archive. I haven't tested 1.0.0 to this one so if you want I can setup a testbed and try it for you but for the most part the only reason this is an addon is that it uses the addon system to install it and thus individual bbcodes are tied to the addon, I don't foresee a problem here...but like I said I can test it for you first if you like.



already mentioned it to him. I was wondering if he could get permission to add it into the package. the less add-ons, the better IMO.

I would ask him yourself if he minds it being added...he knows about the addon and if he wants it to be in here he would have said something I have to assume.

I tried to make it clear in the addon description that I am pretty much merely a steward of this addon and any bbcode that is tested as working, not adult in nature (see MUTT for these), not embedding from illegal type sites and could be of value to the general population of site owners running XF will get added if requested by the creator. In my opinion if his code works well, it is not really my choice as to add it or not, it is his and he should contact me if he wishes it to be added.
 

Rho Delta

Well-known member
Yeah if you could test it first that would be awesome, I don't want to break all of my embedded media lol
 

EQnoble

Well-known member
Ok just to be sure I am testing the same circumstances...
What are you running:​
  • Ver. XF running
  • Version MediaSites Pack (I think we already established this but place a link to the version you have, in your case the thread you downloaded it from)

Also note:

Any bbcodes removed from the list will be broken if people used them (there is only a few of those). BBcodes will get removed from the pack for a multitude of reasons the logic primarily being if they don't work they get removed.

I consider one 'not working' if it breaks due to a change in a website that either makes it so the embed information is unavailable to methods that I know of or if they remove the ability to embed entirely. Others may switch from a completely custom setup for media retrieval to an api of sorts that allows someone to get the information from it and in an event like that the whole bbcode may have to be rewritten and the existing data between the tags in posts will have to be manipulated back to the original url and then worked into the format of what would be captured with the new bbcode. Most major sites are pretty good about the way they do things but there is occasions where things can get ugly and there is really nothing you can do about it unfortunately.
 

Rho Delta

Well-known member
Ok just to be sure I am testing the same circumstances...
What are you running:​
  • Ver. XF running
  • Version MediaSites Pack (I think we already established this but place a link to the version you have, in your case the thread you downloaded it from)

Also note:

Any bbcodes removed from the list will be broken if people used them (there is only a few of those). BBcodes will get removed from the pack for a multitude of reasons the logic primarily being if they don't work they get removed.

I consider one 'not working' if it breaks due to a change in a website that either makes it so the embed information is unavailable to methods that I know of or if they remove the ability to embed entirely. Others may switch from a completely custom setup for media retrieval to an api of sorts that allows someone to get the information from it and in an event like that the whole bbcode may have to be rewritten and the existing data between the tags in posts will have to be manipulated back to the original url and then worked into the format of what would be captured with the new bbcode. Most major sites are pretty good about the way they do things but there is occasions where things can get ugly and there is really nothing you can do about it unfortunately.
I run the most current XF version 1.1.4, no idea what thread I got the original one here, it was like over a year ago, before the RM was out. I mainly use amazon embedding, ebay embedding, and 8tracks. I think my amazon one might be customized to add my affiliate code to the end of each link too but that might be through another add on...
 

EQnoble

Well-known member
I run the most current XF version 1.1.4, no idea what thread I got the original one here, it was like over a year ago, before the RM was out. I mainly use amazon embedding, ebay embedding, and 8tracks. I think my amazon one might be customized to add my affiliate code to the end of each link too but that might be through another add on...

8 tracks and ebay have been fixed in this one and the data between the tags should be the same.

Do you by chance still have the zip file you used? On the storage array that I have connected to my network right now I don't have stuff saved before a certain date, that stuff is in a storage array that I happen to be rebuilding and don't have it connected at the moment.

I tested it with v.1.0.1 and it seems to work just fine. I would say go ahead and give it a whirl.
Of course if you are nervous/cautious export the addon and backup the files in the MediaSites directory first so that if it has negative effects for you, all you would need to do is uninstall the addon and reinstall the old one.
 

Rho Delta

Well-known member
I don't have the original zip file unfortunately. I might try the folder backup and just upgrade.

My current ebay one doesnt even work 100% of the time anyways lol
 

EQnoble

Well-known member
I don't have the original zip file unfortunately. I might try the folder backup and just upgrade.

My current ebay one doesnt even work 100% of the time anyways lol

Yeah I did notice that with that front page feed thing on ebay that some of the links were very different as well...I tried my best to discover all url types but after 3 days straight of doing nothing but updating bbcodes and trying to figure out the complete URL scheme for stupid amounts of sites...I was finally content to call ebay fixed. :)

If for some reason some of the new codes don't allow your previous content to parse properly, please link me so I can see what is missing and then help you with the expressions that you may need for 'replace in posts'.
 

EQnoble

Well-known member
The ESPN code seems to be busted. Tried embedding several links and they all come up blank. Here's one as an example:

http://espn.go.com/video/clip?id=espn:9166527
That has to do with their generated js that generates the embed....something about the combination of what they are doing and using it in a bbcode is causing it to show at the very bottom of the page right above the footer instead of where it is posted. Refreshing the page would show it where it is supposed to be which isn't desirable for me either for the obvious reason of it being stupid.

I have temporarily worked around this in the most recent update.
 

The Grand Potentate

Well-known member
Thanks for fixing the ESPN code.

Next time you update this, is there a chance you could sync the numbering system to it plays nice with Chris' Add-on Installer Updater?
 

EQnoble

Well-known member
Thanks for fixing the ESPN code.

Next time you update this, is there a chance you could sync the numbering system to it plays nice with Chris' Add-on Installer Updater?
Grrrrrr...

I soooo just started using x.x.x_xx for everything...

is changing the naming convention for the .zip to _x.x.x.xx going to fix it...or do I have to do anything else?
 
Top