1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Avatar Uploads not working?

Discussion in 'Troubleshooting and Problems' started by Carlos, Nov 3, 2013.

  1. Carlos

    Carlos Well-Known Member

    So, I just recently moved to a new server courtesy of @Mike Edge but then I see some weird things happening.

    A user tried to upload an avatar several times, and it comes back as a blank image. So today, I was just minding my own business checking things on CODForums, and I found this error:

    getimagesize(/home/root/public_html/codforums.com/data/avatars/l/5/5877.jpg): failed to open stream: No such file or directory Yesterday at 3:36 PM - library/XenForo/Model/Avatar.php:252

    What does this mean? Does this mean the user uploaded the wrong content type, or what?
  2. Amaury

    Amaury Well-Known Member

    Check the server error logs to see if you can get some more detail, or is that error above from the server error logs?
  3. Carlos

    Carlos Well-Known Member

    I'll check the server logs soon, but the above "server error logs" are from the actual xenForo software itself (in ACP, of course).
  4. Amaury

    Amaury Well-Known Member

    Okay, yeah. You should check the error log on the server itself.
  5. Jeremy

    Jeremy XenForo Moderator Staff Member

    The images failed to upload. Have you verified directory permissions?
  6. Carlos

    Carlos Well-Known Member

    It should be solved now, was an issue somewhere in the server. Mike [Edge] was working on it.

    I tried looking for server errors in cpanel, but it only told me when it happened and where - stuff I already know.

Share This Page