• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Both FTP, avatar/file uploads gone mad

mauzao9

Well-known member
#1
Hello.

Yesterday, from sudden, something happened that is causing server errors when uploading something by the site, like Avatars or normal files, and in FTP refusing to upload any file.

This error for both avatars and file uploads:
Code:
Error Info
ErrorException: rename(/home/www/ilovebacons.com/www/data/avatars/l/0/47.jpg): failed to open stream: No space left on device - library/XenForo/Model/Avatar.php:342
Generated By: Burnt Toast, Today at 7:14 AM
Stack Trace
#0 [internal function]: XenForo_Application::handlePhpError(2, 'rename(/home/ww...', '/home/www/ilove...', 342, Array)
#1 /home/www/ilovebacons.com/www/library/XenForo/Model/Avatar.php(342): rename('/tmp/phpNu357S', '/home/www/ilove...')
#2 /home/www/ilovebacons.com/www/library/XenForo/Model/Avatar.php(206): XenForo_Model_Avatar->_writeAvatar(47, 'l', '/tmp/phpNu357S')
#3 /home/www/ilovebacons.com/www/library/XenForo/Model/Avatar.php(69): XenForo_Model_Avatar->applyAvatar(47, '/tmp/phpNu357S', 2, 19, 24, Array)
#4 /home/www/ilovebacons.com/www/library/XenForo/ControllerPublic/Account.php(482): XenForo_Model_Avatar->uploadAvatar(Object(XenForo_Upload), 47, Array)
#5 /home/www/ilovebacons.com/www/library/XenForo/FrontController.php(313): XenForo_ControllerPublic_Account->actionAvatarUpload()
#6 /home/www/ilovebacons.com/www/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#7 /home/www/ilovebacons.com/www/index.php(13): XenForo_FrontController->run()
#8 {main}
Request State
array(3) {
  ["url"] => string(44) "http://ilovebacons.com/account/avatar-upload"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(8) {
    ["use_gravatar"] => string(1) "0"
    ["avatar_date"] => string(1) "0"
    ["avatar_crop_x"] => string(1) "0"
    ["avatar_crop_y"] => string(1) "0"
    ["_xfToken"] => string(8) "********"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(9) "json-text"
    ["_xfUploader"] => string(1) "1"
  }
}
And this error if i try upload anything to our site via any FTP:
Code:
Erro:/home/www/ilovebacons.com/www/emotes.png: open for write: failure
Anyone can point me in the right direction? This is something more than CHMOD permissions since the server itself is refusing any uploads. :(
 

mauzao9

Well-known member
#3
There's your problem. Full disk.
Hey Mike, we just have a look and it can't be:

Filesystem Size Used Avail Use% Mounted on
/dev/mapper/vg0-www 99G 64G 30G 68% /home/www
/dev/mapper/vg0-tmp 5.0G 143M 4.6G 3% /tmp

There's still 30GB available on www.
The /tmp directory also has more than enough space available...

I can't understand, why is he acting like there is not space if the site folders show more than enough?
 

mauzao9

Well-known member
#6
Or a corrupted file system.
Don't you even think of it! Oh dear. We will tomorrow change the forum directories to the basic /home/user without the www, since there this problem isn't happening, at least, i hope so. Just reached the wall what my knowledge about server management can do to fix this.
 

mauzao9

Well-known member
#8
Is that NAS or something? Can your host tell you if it's a bad drive or something?
The host does not manage the server, we do, that's the problem. There are several sites hosted in the server, only the Xenforo directory since yesterday refused any uploads, not even by FTP, but it was fine in the first 2 weeks.

I don't know if this is one signal, that something in hardware is getting damaged, or it is just some mad error or bug.