1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Avatar Problem after upgrade (1.0.3->1.0.4)

Discussion in 'Installation, Upgrade, and Import Support' started by Feedback, Jul 17, 2011.

  1. Feedback

    Feedback Member

    Hey all
    I bumped into a problem after the upgrade to 1.0.4, all users avatar is blank, but all the default avatars can be seen. You can upload a avatar but all you get is a black box.

    avatare error.png avatare error 2.png

    Data and internal_data both have world writeable (CHMOD 0777). I have tried to removed the addons and skins (styles) but nothing have changed:(
    The File Health Check are OK and it is no server error log.
    Rest of the forum works perfectly.

    Thanks for reading
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Including avatars that were uploaded before the upgrade? Can you post a URL to your forum so I can examine the problem?

    Maybe you overwrote the data directory during the upgrade. Or maybe it's a problem with your custom style (try to reproduce it on a default style).
  3. Feedback

    Feedback Member

    Yep, even avatars that was uploaded before the upgrade got the same problem.

    sure, www.gamer-core.net. Say if you need admin user.

    I get the same problem with the default style.
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  5. Feedback

    Feedback Member

    hmmm really weird. data and internal_data are fully writable :/

    as you can see data and internal_data are 777
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Try running this command to recursively set permissions in those directories:

    chmod -R 777 data
    You might also try 755 permissions. Depending on how PHP is installed, 755 may still be writable. I have seen some server configurations throw 403 errors with 777.
  7. Feedback

    Feedback Member

    tried both 777 and 755, and no luck :S when it was 1.0.3 the permissions was 755 on both folders.
    both folders have permission 755 now btw
  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  9. borbole

    borbole Well-Known Member

    I get a 403 forbidden error as well when I try to view the avatars directly. I have had a similiar issue with a client, but on a different forum, and the issue was that he had lost ownership of the files. Meaning that only the host could chmodd them. The problem was solved by contacting the host and getting them to transfer the file ownsherip back.
    Can you contact your host as well and ask them about it? It might be worth a shot.
  10. Feedback

    Feedback Member

  11. TazDevilLooney

    TazDevilLooney Active Member

  12. Feedback

    Feedback Member

    After a talk with my host provider, it turned out that they had a .htaccess file on the security server directed to my host server. Do not know why, but it works now :)

    But I want to thank you all for the nice feedback :p
    TazDevilLooney likes this.
  13. betnod

    betnod Member

    For some reason my avatars stopped uploading to server , no error messages just red x's, even chmodding all the relevant directories they still would not show.

    using ssh(putty) I ran
    chmod -R 777 data
    chmod -R 777 internal_data
    in the root of the install and now they work fine again.

    Thanks Jake.

Share This Page