As designed Automatically reject registrations not working

Affected version
v2.1.6 Patch 1

dash

Member
Hi,

I have set up the spam options to automatically reject registrations when 2 warning flags are detected as per this option:

1.jpg

When I get registrations with 2 or 3 warning flags, they do not automatically get rejected. They go to the approval queue.

1579315888844.png
Any idea why it is not automatically rejecting them?
 

whynot

Well-known member
Did you try to uncheck "Moderate registrations when this many warning flags are detected" ?
 

dash

Member
Did you try to uncheck "Moderate registrations when this many warning flags are detected" ?
No. I did not uncheck. The behaviour I am looking for is exactly as selected:

1) Moderate when 1 warning flag is detected (checked)
2) Automatically reject when 2 or more warning flags are detected (checked)

Can someone explain how this is supposed to function? Seems like a bug.
 

Chris D

XenForo developer
Staff member
Your understanding of how it should work is correct though I haven’t had a chance yet to reproduce the issue.
 

Mike

XenForo developer
Staff member
Your screenshot doesn't show the "Only count flags recorded at least this many times" configuration (lower in the StopForumSpam option). By default, that's 5, thus the example email: 3, ip: 6 match only has 1 flag counted.
 

dash

Member
Just checked. The "Only count flags recorded at least this many times" setting is set at 5. Never changed it. Didn't realize the numbers beside the matches meant something. So since mine is set to 5, in that example, IP is considered a flag at 6, email is not since it is 3.

Get it now. Not a bug. Thank you for the clarification.
 
Top