1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Automated bounced email setup issue

Discussion in 'Troubleshooting and Problems' started by tommydamic68, Mar 2, 2016.

  1. tommydamic68

    tommydamic68 Well-Known Member

    So I tried to set up automated bounced email system and it appears to not be working, any input would be appreciated. here is what I have in my settings and on my email account on the server. I tried a test bounce email and it did not work.

    Screen Shot 2016-03-02 at 5.29.46 AM.png Screen Shot 2016-03-02 at 5.30.35 AM.png
     
  2. Martok

    Martok Well-Known Member

    Have you logged into the bounce email account to see if it received a bounced email?
     
  3. tommydamic68

    tommydamic68 Well-Known Member

    Yes. I changed my email accounts email address on the site to a non working email and sent a test conversation to it and my server did pick it up as a bad address, but nothing went to the bounce email account. And I sent just a regular "test" bounced email account to ensure the email account is working and it did receive the regular test email.
     
  4. Mike

    Mike XenForo Developer Staff Member

    Can you show the configuration you're using to send emails in XF?
     
  5. tommydamic68

    tommydamic68 Well-Known Member

    This mike?

    Screen Shot 2016-03-02 at 6.03.05 AM.png
     
  6. Mike

    Mike XenForo Developer Staff Member

    Umm, there aren't any email transport methods selected? That shouldn't happen. I have to guess you have (or had) an add-on installed that manipulated this?
     
  7. tommydamic68

    tommydamic68 Well-Known Member

    The only email add on was [BD] mail. But its uninstalled for a week or so. Should I add content in there and what needs to be added. Honestly I don't recall anything being there in the past. Emails do work fine on the site, as expected.
     
  8. Mike

    Mike XenForo Developer Staff Member

    You should choose the default option and have the return path option selected. (The bounce config mentions it might not function without this.)
     
  9. tommydamic68

    tommydamic68 Well-Known Member

    I did so with F perimeter and it worked. Thank you. Side note (it did not change that test user from being a "valid" state however.)
     
    Last edited: Mar 2, 2016
  10. Mike

    Mike XenForo Developer Staff Member

    What does the email bounce log show in the control panel? It's not an instantaneous process; it's checked every 30 minutes. Note that you reading the mail may cause XF to not read it for processing.
     
  11. tommydamic68

    tommydamic68 Well-Known Member

    I will check It later Mike and retest without opening the bounced email. Thanks again.
     
  12. tommydamic68

    tommydamic68 Well-Known Member

    Im recieving this server error.

    Code:
    Zend_Mail_Storage_Exception: cannot login, user or password wrong - library/Zend/Mail/Storage/Imap.php:279
    Generated By: Unknown Account, 4 minutes ago
    Stack Trace
    #0 /home/admin/public_html/community/library/XenForo/Model/EmailBounce.php(292): Zend_Mail_Storage_Imap->__construct(Array)
    #1 /home/admin/public_html/community/library/XenForo/Deferred/EmailBounce.php(19): XenForo_Model_EmailBounce->openBounceHandlerConnection()
    #2 /home/admin/public_html/community/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_EmailBounce->execute(Array, Array, 7.99999904633, '')
    #3 /home/admin/public_html/community/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.99999904633, '', false)
    #4 /home/admin/public_html/community/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #5 /home/admin/public_html/community/deferred.php(23): XenForo_Model_Deferred->run(false)
    #6 {main}
    Request State
    array(3) {
      ["url"] => string(44) "http://sphynxlair.com/community/deferred.php"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(4) {
        ["_xfRequestUri"] => string(39) "/community/threads/izmaes-dinner.35411/"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfToken"] => string(8) "********"
        ["_xfResponseType"] => string(4) "json"
      }
     
  13. Fred.

    Fred. Well-Known Member

    Can you post an updated screenshot so we can see you have the correct settings?
     
  14. tommydamic68

    tommydamic68 Well-Known Member

    I have multiple server errors now.

    Screen Shot 2016-03-03 at 5.18.08 AM.png
     
  15. tommydamic68

    tommydamic68 Well-Known Member

    Here are my current settings.

    12.png 222.png
     
  16. Mike

    Mike XenForo Developer Staff Member

    This indicates that your bounce handler IMAP details are incorrect. You'll need to check with your mail provider.
     
  17. tommydamic68

    tommydamic68 Well-Known Member

    Ok, I think the issue may have been the password to the email account being incorrect in the ACP. So I did a test today again (did not open bounced email) It shows the bounce email in the email log and on my email server but the user still remains valid. Any thoughts?

    Screen Shot 2016-03-04 at 5.45.58 AM.png
     
  18. Martok

    Martok Well-Known Member

    A user is only made invalid immediately if it was a hard bounce. If it was a soft bounce, then the soft bounce criteria you have set will apply.

    More details here: https://xenforo.com/community/threads/automated-bounce-email-handling.78137/
     
    tommydamic68 likes this.
  19. Mike

    Mike XenForo Developer Staff Member

    Also, that user is a moderator. There are specific exemptions for staff members (as it prevents them from losing permissions, similar to them not having to manually confirm their email after changing).
     
    tommydamic68 likes this.
  20. tommydamic68

    tommydamic68 Well-Known Member

    So correcting the password to my bounced email account was the issue for the server errors. Also, after removing the user from being moderator, test the email bounce system again, it was a "hard" bounce, it then put the user state as expected "email invalid (bounced)." Once the email was corrected it made the account valid again. Thanks for the help everyone.
     
    Fred. likes this.

Share This Page