1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Attachment Upload Apache DSO vs FCGI

Discussion in 'Troubleshooting and Problems' started by MRaburn, Oct 20, 2011.

  1. MRaburn

    MRaburn Active Member

    I installed the latest Beta and was not able to upload, it was that stuck at 100% and even turning off the Flash Uploader the normal one does not work.

    I had moved my sites to a new server this week and decided to set this box up on FCGI over DSO for sudo reasons to see php owners.

    I have another copy of 1.0.4 running on my other site on the same box that i knew was working for attachments. I tested it and the uploader was broke as well.

    After reading threads on here a lot seems to be pointing to some FCGI possibilities. I changed the box back to DSO to test and the upload works on both sites now, one being 1.0.4 and the other 1.1 beta 3.

    So something in FCGI causes the issue, maybe ownership? I even tried suexec on and off. It's my own dedicated box if you guys need me to test anything.

    Mike
     
  2. MRaburn

    MRaburn Active Member

    Well crap... check that.

    Running PHP as DSO on 1.0.4 works. Not on FCGI
    Running PHP as DSO on Beta 3 nor FCGI.

    Makes me believe its entirely a permissions issue.
     
  3. MRaburn

    MRaburn Active Member

    Well I have tried every permission setting I can think of to make it work.

    On 1.04 - I can get an upload to work running as DSO and ownership of data and attachments folder is nobody. Running this same setup as FCGI it will not work.

    On Beta 3 - I cannot get it to work period with ownership being the actual account, and as nobody on DSO and FastCGI. This is as flash uploader and normal.

    Stuck. ;)
     
  4. MRaburn

    MRaburn Active Member

    OK one more weird test.

    On 1.0.3 - If I load the page while on DSO I can upload an attachment and the loader shows the thumbnail. THEN if I change the server back to FCGI and DO NOT refresh the page, the uploader works. IF I then refresh the page while in FCGI, it gets stuck on 100% again.

    Any other tricks to try?
     
  5. Mike

    Mike XenForo Developer Staff Member

    I have to admit, the permutations here are confusing - it's hard to know what's owned by who. (And is this Linux?) We do try to chmod the directories/files to be 0777, but that is based on the server setup at install time. If it changes, all bets are off.

    If you disable JavaScript and upload, do you get an error message?
     
  6. MRaburn

    MRaburn Active Member

    Mike,

    I know it was a ramble, but I kept digging after my initial post and then would reply as I learned more.

    Here is where we are at.

    I had to switch to DSO and all works fine.

    In FCGI I can upload a 162kb file no problem. BUT a file that is 182k Fails. It just hangs on the uploader, this is Flash or Standard.

    I played with PHP and Apache settings making sure upload, script times, memory and all were up to par, but that did not help. I mean a file size of 10k difference is the trigger. At this point I have no idea what the cuprit is.

    Could this be a mysql setting I could try for blobs?
     
  7. Mike

    Mike XenForo Developer Staff Member

    No, nothing is stored in the database. It sounds like with the FCGI setting, it's blocking or truncating the request when it goes over a certain length. Honestly, I'm not sure where that would be configured, but I don't think it's to do with PHP itself -- that sounds like something with your web server or FCGI config.
     
  8. MRaburn

    MRaburn Active Member

    Yep. Thanks for taking the time to check my thread.

    Gotta be buried in FCgi somewhere. Its my own box and Im the only one running stuff on there so DSO is fine.

    Ill be moving our 4mil post website over sometime soon after final 1.1 comes out.

    Thanks!!
    Mike
     
    Mike likes this.

Share This Page