XF 2.2 [Attach] In profile post, search result

Geiri

Active member
I search and get a few results like this.
I can search for the word Attach to get the results or other words
This are all from profile posts


1667929861819.png
 

Tracy Perry

Well-known member
What are you trying to find?
Searching for an attachment using the phrase attach is realistically not going to return anything since the word attach is most likely not part of the content.
 

Geiri

Active member
@Tracy Perry I may not have been clear :)
This Bracket should not be visible, should it?
That is what is bugging me. My point was that I can call it by searching for ATTACH and it shows only in Profile posts

XENBRACKET-1.jpg
 

Tracy Perry

Well-known member
Now that I'm not sure about.. I don't know why there would be a prefix of [Attach} in a profile post.... I've got some attachments here on some of my conversations, and it does NOT show up. So I have to wonder... are you using any add-ons that deal with profiles or attachments?
 

Geiri

Active member
Now that I'm not sure about.. I don't know why there would be a prefix of [Attach} in a profile post.... I've got some attachments here on some of my conversations, and it does NOT show up. So I have to wonder... are you using any add-ons that deal with profiles or attachments?
Not that I am aware of...

1669048456030.png
 

beerForo

Well-known member
It happens here on XF too. Advanced Search, chose Profile Posts, and term attach.

What is happening is XF is not wanting to show the image in the result, so maybe, this is telling you an image exists? I agree it is an ugly way. Visible bbcode.
 

Geiri

Active member
It happens here on XF too. Advanced Search, chose Profile Posts, and term attach.

What is happening is XF is not wanting to show the image in the result, so maybe, this is telling you an image exists? I agree it is an ugly way. Visible bbcode.
I thought for sure it was a bug :/
 

Tracy Perry

Well-known member
It happens here on XF too. Advanced Search, chose Profile Posts, and term attach.

What is happening is XF is not wanting to show the image in the result, so maybe, this is telling you an image exists? I agree it is an ugly way. Visible bbcode.
You mean like this?

Screen Shot 2022-11-21 at 4.32.09 PM.png

I get this.

Screen Shot 2022-11-21 at 4.32.26 PM.png

Now, granted I have no posts that have a file "attached" using the insert files command and just sitting there as an attachment not in the post, but I do have at least one post with an image attached to it on my site.
 

Tracy Perry

Well-known member
Leave out the username and you will see it.
Yep... but I honestly don't see how they can do a lot differently... and I'm pretty sure you are correct in that it is simply a methodology to show that there is something attached to that post. I don't think they can really change it to something [IMAGE] effectively, because you CAN attach actual files to a profile post if the permissions are set appropriately.
 
Top