1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Asking for an upgrade after server move

Discussion in 'Troubleshooting and Problems' started by Moshe1010, Jul 20, 2013.

  1. Moshe1010

    Moshe1010 Well-Known Member

    Hi,

    I've moved a server (1.2RC1), and when everything was done in terms of the migration, XenForo says that there is an upgrade pending and I should upgrade. When I click on this upgrade, it says no installation files were found.
    Not sure if I should upload RC1 packet again and update the system?
     
  2. Mike

    Mike XenForo Developer Staff Member

    If it says an upgrade is pending, then the files differ from the version found in the database. If you recently did an upgrade, either the database or the files could be out of date (from what they're supposed to be). If it's the database, you'll be missing other data so that's a big deal.

    Regardless, at the least, you'd need to restore the files from the correct version or from whatever version you wish to upgrade to. The easiest thing would be to reupload the RC1 file and go from there, but be vigilant for missing threads/posts.
     
  3. Moshe1010

    Moshe1010 Well-Known Member

    Thanks. I've uploaded the files and it disappeared. One last question: when I enable Friendly URLs, it says, I get a blank page. I think it's .htaccess issue? this is how it looks like right now:

    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    <IfModule mod_rewrite.c>
        RewriteEngine On
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /forum
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    Mod_security is enabled on my server, but I have no idea what that doesn't work. I did change the route of the board to:
    IP/~xen from subdomain.domain.com

    Thanks.
     
  4. Mike

    Mike XenForo Developer Staff Member

    If you're using the standard /~dir method, you'll need to uncomment the RewriteBase line to /~dir. Otherwise, you may need to check your server error log to see if there are any details.
     
  5. Moshe1010

    Moshe1010 Well-Known Member

    Tried to delete the # before the RewriteBase and set /~xen instead of /forum, but that didn't work. I get a white page.
    This is what I get in my error log:


    Code:
    2013-07-21 05:00:30.168 [NOTICE] [/home/xen/public_html/.htaccess:8] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
    2013-07-21 05:00:30.168 [NOTICE] [/home/xen/public_html/.htaccess:9] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
    2013-07-21 05:00:30.168 [NOTICE] [/home/xen/public_html/.htaccess:10] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
    2013-07-21 05:00:30.168 [NOTICE] [/home/xen/public_html/.htaccess:11] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
    Not sure of it's relevant.
    http://img5.imageshack.us/img5/2964/0mb0.png
     
  6. Mike

    Mike XenForo Developer Staff Member

    I'm guessing you're using Litespeed? That looks like something they're not compatible with compared to Apache, though it's just a notice.

    Litespeed may have other compatibility issues with the rewrites in that situation then - may be worth contacting them.
     
  7. Moshe1010

    Moshe1010 Well-Known Member

    Yes, I run LiteSpeed, but I had LiteSpeed on the previous server as well, so I'm not sure. I've managed to get to something like that on my index:
    http://img9.imageshack.us/img9/4880/ol35.png

    It says on the middle of the page that /~xen doesn't exists, but the url is IP/~xen
    The board works perfectly with Friendly URLs disabled.
     
  8. RoldanLT

    RoldanLT Well-Known Member

    I have the same error on cpanel logs.
     
  9. Moshe1010

    Moshe1010 Well-Known Member

    That's because you have an error page that doesn't exists. Create it or delete it from your htaccess
     
  10. RoldanLT

    RoldanLT Well-Known Member

    I'm just using the default XenForo Error page/document Declared.
    Code:
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
     
  11. Moshe1010

    Moshe1010 Well-Known Member

    Right. The document that is declared doesn't mean there is an error page associated to it on the server level. These errors can be ignored/changing your htaccess, or creating these error pages with an empty shtml/html file or do a custom one.
    I just created empty files and my log is pretty clear now.
     

Share This Page