1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 APC: Unable to allocate memory for pool.

Discussion in 'Troubleshooting and Problems' started by Marcus, Nov 12, 2013.

  1. Marcus

    Marcus Well-Known Member

    I get this error with latest APC / nginx (installed from @eva2000 centminmod). In my config.php there is "ini_set("memory_limit","256M");"

    An exception occurred: include(): apc_compile_cache_entry: Unable to allocate memory for pool. in /home/nginx/domains/domain.com/public/library/XenForo/Autoloader.php on line 120

    1. XenForo_Application::handlePhpError() in XenForo/Autoloader.php at line 120
    2. XenForo_Autoloader::autoload() in XenForo/Autoloader.php at line 120
    3. XenForo_Autoloader->autoload() in XenForo/Application.php at line 1000
    4. XenForo_Application::autoload() in XenForo/Application.php at line 450
    5. XenForo_Application::resolveDynamicClass() in XenForo/FrontController.php at line 429
    6. XenForo_FrontController->_getValidatedController() in XenForo/FrontController.php at line 329
    7. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    8. XenForo_FrontController->run() in /home/nginx/domains/domain.com/public/admin.php at line 13
  2. Marcus

    Marcus Well-Known Member

    That solves it: In apc settings (either php.ini or the loaded additional apc.ini):


    96M were not enough :/

Share This Page