1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Allocation for memory pool?

Discussion in 'Installation, Upgrade, and Import Support' started by Joshua, Apr 13, 2014.

  1. Joshua

    Joshua Active Member

    Just got this error message. I just moved to a CentMinMod droplet on Digital Ocean. Still ironing out the configuration settings. Any assistance is greatly appreciated!

    Code:
    An exception occurred: include(): Unable to allocate memory for pool. in /home/nginx/domains/domain.org/public/library/XenForo/Autoloader.php on line 119
    
    [LIST=1]
    [*]XenForo_Application::handlePhpError() in XenForo/Autoloader.php at line 119
    [*]XenForo_Autoloader::autoload() in XenForo/Autoloader.php at line 119
    [*]XenForo_Autoloader->autoload()
    [*]spl_autoload_call() in XenForo/FrontController.php at line 375
    [*]XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    [*]XenForo_FrontController->run() in /home/nginx/domains/domain.org/public/admin.php at line 13
    [/LIST]
    
     
  2. Sheratan

    Sheratan Well-Known Member

    Do you use any PHP cache like APC/xcache?
     
    Joshua likes this.
  3. Joshua

    Joshua Active Member

    I'm wanting to use memcache but something tells me it isn't working properly
     
  4. Sheratan

    Sheratan Well-Known Member

    I have once encountered the same problem. The problem is APC running out of memory.

    If you had any php cache or maybe memcache/memcached/libmemcache, try to disable that. Then restart your nginx and PHP.

    Dont forget about Zend OPcache in PHP 5.5 :)
     
    Joshua likes this.
  5. Joshua

    Joshua Active Member

    So you're saying if I disable all PHP cache methods and restart nginx and php, this should stop happening? It seems to be intermittent.

    And what about Zend OPcache? What if I prefer to use memcache?
     
  6. Sheratan

    Sheratan Well-Known Member

    I cant say, but after I disable all PHP cache and then restart nginx and PHP, the error is gone.

    It could be the same problem (cache is full or misconfiguration), it could be something else. You can try to check your server error log for more information.

    I see some people using PHP 5.5 without realize they are installing Zend OPCache too by default. So when they try to install APC... boom! :D

    Zend OPCache + memcache is good alternative. :)
     
  7. Tracy Perry

    Tracy Perry Well-Known Member

    Memcache is really overkill on a small VPS - and if your site is big enough to really need it then it would probably be better severed on dedicated hardware. I am aware that there are some VPS's that allow 6-8GB RAM, but your constraints will usually be elsewhere then.
     
  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  9. Joshua

    Joshua Active Member

    How can I turn off APC and use Zend OPcache and memcache? This is a 16GB RAM Digital Ocean droplet
     
  10. Tracy Perry

    Tracy Perry Well-Known Member

    Going to depend on whether you are using nginx, Apache or OpenLiteSpeed.
    nginx by removing the module from the /php5/fpm/conf.d, Apache probably by removing the module from the php.ini, OpenLiteSpeed by removing the APC option at compile time of PHP and adding it to the compile options when compiling php for OLS and then adding it into the php.ini.
    The below enables it for 1.2.9 of OLS.
    Code:
    zend_extension=/usr/local/lsws/lsphp5/lib/php/extensions/no-debug-non-zts-20121212/opcache.so
     

Share This Page