[AP] Character Counter

[AP] Character Counter 1.2.1

No permission to download
Thank you very much for this nice little addon ;)

Is there any chance to use phrases for the "Characters"?
Permission function does not work, counter is displayed to all who can see the editor.
 
how about a countdown based on the characters post limits? Twitter style
I like the idea and I'll keep it in mind, but might not be easy to do since all my addon really is doing is toggling a feature that's already built into the Xenforo editor but comes disabled out of the box. I'll still give it a shot though

Thank you very much for this nice little addon ;)

Is there any chance to use phrases for the "Characters"?
Permission function does not work, counter is displayed to all who can see the editor.
Likewise, changing "characters" to a phrase might be a bit tricky for the above reason, but I also like the idea and am willing to give it a shot.
Noted about the permission, I'll try get that sorted soon.
 
I like the idea and I'll keep it in mind, but might not be easy to do since all my addon really is doing is toggling a feature that's already built into the Xenforo editor but comes disabled out of the box. I'll still give it a shot though


Likewise, changing "characters" to a phrase might be a bit tricky for the above reason, but I also like the idea and am willing to give it a shot.
Noted about the permission, I'll try get that sorted soon.
I was asking myself the same question, I tried to translate the "Characters:" into my language, but it ignores the variable in Spanish. It would be great to be able to edit it in addon phrases too ;)
 
Hi, Thank you very much for the update, but I ran into a problem.
If I activate the permission so that users can see the character counter, the quick editor does not let them write.

If I deactivate the permission to see the character counter, it already allows writing but the character counter is not seen.

Edit: If I select words in the options instead of characters, the problem is the same, since the advanced editor does not allow typing.
 
I don't even see the counter at all in the editor (And yes the permission was given)

Are there any additional steps?
 
I don't even see the counter at all in the editor (And yes the permission was given)

Are there any additional steps?
There shouldn't be no, can you try on the default style? It would rule out if its a third-party theme compatibility issue or not.

Hi, Thank you very much for the update, but I ran into a problem.
If I activate the permission so that users can see the character counter, the quick editor does not let them write.

If I deactivate the permission to see the character counter, it already allows writing but the character counter is not seen.

Edit: If I select words in the options instead of characters, the problem is the same, since the advanced editor does not allow typing.
Sorry for the late reply I was out and about, I ran into a similar issue where I couldnt type when Counting down was enabled during testing but it was because I was applying the $maximumMessageLength - $currentCount calculation in the wrong place, after a bit more messing around it worked for me... I've been kind of inactive development-wise due to IRL problems, but I'm getting back into things now and I'll try have a look at both yours and Jordan's reports in the next few days.
 
There shouldn't be no, can you try on the default style? It would rule out if its a third-party theme compatibility issue or not.


Sorry for the late reply I was out and about, I ran into a similar issue where I couldnt type when Counting down was enabled during testing but it was because I was applying the $maximumMessageLength - $currentCount calculation in the wrong place, after a bit more messing around it worked for me... I've been kind of inactive development-wise due to IRL problems, but I'm getting back into things now and I'll try have a look at both yours and Jordan's reports in the next few days.
Hi,
Don't worry, when you can and have time.

We will wait for that update in the meantime, I already tried to make all kinds of changes, but with the new version it does not allow writing if you activate the permission for that group of users.

I've been all afternoon/night looking for where the problem could come from, but I gave up, I'm leaving it disabled until a new update.

Thank you, very much and happy holidays ;)
 
I don't suppose theres a way to make it so quoted messages don't count towards word count huh?
 
No difference is made between a topic/post or a profile message. @apathy can you fix?
If you mean to say you dont want the counter to show up in the Profile Post editor, I'll see if I can get a toggle for allowing it to appear in specific locations

I don't suppose theres a way to make it so quoted messages don't count towards word count huh?
Unlikely right now, I had a quick try and funny enough the quote tags don't actually seem to appear when the text is being counted, so there's no immediately obvious way of removing the quote... I have it on the to-do list to try in the future though!



@javilonas and @JordanH I'm not having any luck reproducing your issues - with the addon active, and when viewing the rich editor, do you see any errors in your browser consoles?
 
@javilonas and @JordanH I'm not having any luck reproducing your issues - with the addon active, and when viewing the rich editor, do you see any errors in your browser consoles?
I actually got it working :P

There was two different permissions with the same setting. Wondering if another addon I have installed has something similar xD
 
If you mean to say you dont want the counter to show up in the Profile Post editor, I'll see if I can get a toggle for allowing it to appear in specific locations
No, that's not what he means. It is not displayed correctly in the profile messages.
 
If you mean to say you dont want the counter to show up in the Profile Post editor, I'll see if I can get a toggle for allowing it to appear in specific locations


Unlikely right now, I had a quick try and funny enough the quote tags don't actually seem to appear when the text is being counted, so there's no immediately obvious way of removing the quote... I have it on the to-do list to try in the future though!



@javilonas and @JordanH I'm not having any luck reproducing your issues - with the addon active, and when viewing the rich editor, do you see any errors in your browser consoles?
No, it doesn't show any errors, it just doesn't allow anyone to write when it's active.
 
Top Bottom