1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"An unexpected exception occurred"

Discussion in 'Troubleshooting and Problems' started by SneakyDave, Oct 6, 2010.

  1. SneakyDave

    SneakyDave Well-Known Member

    EDIT: This should probably be moved to "bugs"?

    Sorry, the title should be "An unexpected exception occurred"

    I saw I had an alert of some type on my local installation, clicking the "Alerts" link gave me this non-formatted error message.
    The URI for this was at index.php?account/alerts

    Is it possible to turn on error reporting at some level to see all errors?
  2. SneakyDave

    SneakyDave Well-Known Member

    Ah, I was able to get this logged to the server log....

    ErrorException: Undefined index: today - library/XenForo/Locale.php:530
    I can provide the stack trace, and the other useful information if anybody wants it.
  3. Andy Huang

    Andy Huang Well-Known Member

    Seems like your phrase cache is incomplete.

    Try to rebuild your phrase cache. If you encountered the timeout error during installation, then try running installation again should get you started. If not, editing and reverting a phrase should trigger it to rebuild the indexes, too.
    wwwicked likes this.
  4. SneakyDave

    SneakyDave Well-Known Member

    I didn't get a timeout error during installation, but I haven't seen the error since, and I've rebuilt all my cache.
  5. Omri.L

    Omri.L Active Member

    Same error for me, in the alerts page...
  6. dmnkhhn

    dmnkhhn Active Member

    Did a cache rebuild help?
  7. Omri.L

    Omri.L Active Member

    How do it do that?
  8. Andy Huang

    Andy Huang Well-Known Member

    If you're already installed, you can try to run the installer again (just make sure it doesn't actually re-install but instead reload the xml and re-build the cache). Alternatively, if you feel safer, edit a phrase, and revert it, that should also trigger the cache rebuilding process.
  9. Rich

    Rich Active Member

    How do I do this on a site I cant open?
  10. Andy Huang

    Andy Huang Well-Known Member

    If you cannot open it, then re-running the install script seems like the only option you have available right now. Make a backup of your data first, of course.
  11. doobbe

    doobbe Member

    Same here, just rebuild master data.
  12. Cobro

    Cobro Member

    I ran into this problem also with my one of my host and i saw that it was a problem with when i was upgrading the Zend framwork in cpanel.. So i did not do anything and today voila all fine :)

    just check all error logs and then go from there and start all nessesary tasks to fix the problem..

Share This Page