1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

An unexpected database error occurred. After server change!

Discussion in 'Troubleshooting and Problems' started by jgas, May 17, 2011.

  1. jgas

    jgas Active Member

    Hi guys, I moved my xenforo board to a new server :)
    I changed the server configuration to meet vbulletin requirements and xenforo was working fine, but after seeing that my wordpress installation weren't working, I switched back to the original server configuration and now my xenforo is not working anymore :(

    "An unexpected database error occurred. Please try again later."
    On every page!

    What can I do?
    When I was running vbulletin (a different domain on the same server) I solved changing from mysqlI to mysql..but here I don't know how to change it

    My website is: http://www.pensadifferente.it

    many thanks!
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Have you tried restarting the server since the move and reconfiguration?

    Was XenForo originally working on the current configuration?
     
  3. Rudy

    Rudy Well-Known Member

    Just a wild stab--is it possible a web host might not have support for mysqli in their build of PHP5? I was actually reading through some of their documentation yesterday, and it seems that support for MySQL is no longer bundled in and IIRC, you have to compile in support for both mysql and mysqli. (Don't quote me on it though...I was troubleshooting some code I've been having problems with, and stumbled across it rather hastily.)
     
  4. Wuebit

    Wuebit Well-Known Member

    An unexpected database error occurred. Please try again later.
    <!-- The Mysqli extension is required for this adapter but the extension is not loaded -->

    Remmber you can view the page source to find out about the error <3 xenforo
     
    jgas likes this.
  5. Mike

    Mike XenForo Developer Staff Member

    The source of that page (a database error) actually has the error text:
    Indeed that is the issue. You will have to contact your host. The new server does not meet XenForo's requirements.
     
    jgas and Vodkaholic like this.
  6. Wuebit

    Wuebit Well-Known Member

    Love you mike :3 for adding awesome things like that ^_^
     
    Darkimmortal likes this.
  7. Brogan

    Brogan XenForo Moderator Staff Member

    I just learned something new.

    Nice.
     
    Vodkaholic likes this.
  8. jgas

    jgas Active Member

    Many thanks guys!!!
    I'm rebuilding apache with mysqlI, I'll report later
     
  9. jgas

    jgas Active Member

    Yes, after installing mysqli i'm back online!
     
    Vodkaholic likes this.

Share This Page