1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

An exception occurred: The Mysqli

Discussion in 'Troubleshooting and Problems' started by arabic, May 29, 2011.

  1. arabic

    arabic Member

    An exception occurred: The Mysqli extension is required for this adapter but the extension is not loaded in /home/us/public_html/library/Zend/Db/Adapter/Mysqli.php on line 291

    Zend_Db_Adapter_Mysqli->_connect() in Zend/Db/Adapter/Abstract.php at line 315
    Zend_Db_Adapter_Abstract->getConnection() in XenForo/Application.php at line 547
    XenForo_Application->loadDb() in XenForo/Application.php at line 774
    XenForo_Application->lazyLoad() in XenForo/Application.php at line 804
    XenForo_Application::get() in XenForo/Model.php at line 161
    XenForo_Model->_getDb() in XenForo/Model/DataRegistry.php at line 138
    XenForo_Model_DataRegistry->_getMultiFromDb() in XenForo/Model/DataRegistry.php at line 97
    XenForo_Model_DataRegistry->getMulti() in XenForo/Dependencies/Abstract.php at line 134
    XenForo_Dependencies_Abstract->preLoadData() in XenForo/FrontController.php at line 125
    XenForo_FrontController->run() in /home/xenforoa/public_html/index.php at line 13
  2. James

    James Well-Known Member

    Do you have MySQLi installed? XenForo performs checks at installation so you should have.
  3. Mike

    Mike XenForo Developer Staff Member

    This sounds like something that would've happened after a server move or a PHP upgrade (without all the required extensions). The MySQLi extension must be loaded with PHP.
  4. justwordme

    justwordme Active Member

    I got this same error over the weekend...... I'm an ultra noob on the server side of things. What needs to be done to fix this error on my site???
  5. Brogan

    Brogan XenForo Moderator Staff Member

    Please don't post the same issue on multiple threads.

    In most instances you would be better off starting a new thread to receive support related to your own installation.
  6. justwordme

    justwordme Active Member

    Sorry I thought this thread was from 2012 my bad I wasn't paying attention to the date as closely as I thought.......... Brogan two posts yet your only comment isn't to help only a request to more properly ask a question??? The first post was a generic that happened this weekend, this post is directly related to my issue (I figured it out thanks though)
  7. Brogan

    Brogan XenForo Moderator Staff Member

    My role is forum moderator.

    I voluntarily provide support, but I am certainly not obliged to.
  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    You need to ask your host or server person to install the mysqli extension in PHP. That will fix the error.

Share This Page