• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Amazon SES & xF's Contact Us

TheBigK

Well-known member
#1
I've discovered a new problem using Amazon SES service to handle all of xenForo's outgoing email. Whenever someone tries to contact us via 'Contact Us' form on xenForo, an error message is generated in AdminCP. This is because the xenForo sends outgoing email from sender's email; which isn't verified as a valid sender in Amazon SES.

Is it possible to send email using a verified sender (maybe admin's email) but with users's email listed in the body of email itself?
 

Andy.N

Well-known member
#3
This is not a new issue as many people who use SES has mentioned this before. I have the same issue so I redirect the contact link to a page where people can fill the form and I will get an email sending from my verified SES account.
 

TheBigK

Well-known member
#4
This is not a new issue as many people who use SES has mentioned this before. I have the same issue so I redirect the contact link to a page where people can fill the form and I will get an email sending from my verified SES account.
Could you please write about how you've implemented it?
 

Andy.N

Well-known member
#5
There are 2 addons here that you can use
Simple form by @LP-John
and Advanced form by @Snog

On my site footer, I have a contact link which will get redirected to one of the form where I will get emailed when someone contact me
Try it quantnet.com
 
#6
I do not feel having to pay for an addon to resolve this issue should be required. I have recently setup Amazon SES as well and have also discovered the issues with the contact form. I was about to post on this problem today till I saw this post. Why are we not allowed to change the built in XenForo contact form sender email address and name? I do not even understand why it tries to send/spoof from the users email address when all that info is contained in the contact email body itself anyhow. It should be using the STMP sender we setup in XenForo that is used to send everything else out i.e. Registration emails, Password resets etc... This is probably not just an issue with SES, but most likely other people implementing smtp services would experience this.

Xenforo devs - Is there anyway to change the contact form sender email address to correct this?
 
#9
Well I guess I could use Server Error Log to see when someone uses the contact form haha. Since Simple Forms doesn't appear to support captcha in it, kind of out of options and I gave up trying to modify the mail scripts. If anyone else has a plugin that I am not seeing or has another solution I am all ears.
 

Andy.N

Well-known member
#11
I'm using WuFoo form on a page and the customised the URL through admincp. It was a ready to customise option which I skipped. Working fine now :)
Is it a free form that you can embed or is it having wufoo logo? ;)
I used it a long time ago and was paying for it but no longer use it.
 
#12
@TheBigK interesting idea, maybe I will just do that. I took a look at it on your website and looks to have captcha option too at least from the demo form builder on WuFoo website. I guess this will work till this is resolved in XenForo.