1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 All New Threads Being Posted As Replies Into Old Threads

Discussion in 'Troubleshooting and Problems' started by TheJoker, Apr 7, 2013.

  1. TheJoker

    TheJoker Member

    Hi, I'm running 1.1.4, and I just set up some RSS/Registered feeds. My problem is that the content being pulled from the RSS feeds is being posted into old threads from various places on the forum.

    For example, I just created a section so that it had zero posts. I set up the feed, ran the import, and it pulled a random thread, put it in the new section, and replied to it with the RSS content.

    Here's the site: http://sociallydeficient.com/

    Admin CP access available upon request; any help appreciated!

    EDIT: For example: this section had zero posts: http://sociallydeficient.com/forums/the-coliseum.55/

    I ran the RSS import, and it picked a bunch of threads that were in a private section, moved them, and then posted the new content as a reply.
  2. TheJoker

    TheJoker Member

    Fixed. Thanks, DRE. I appreciate it.
  3. TheJoker

    TheJoker Member

    Curious - would this be better suited for a ticket?
  4. TheJoker

    TheJoker Member

    This actually doesn't seem to be limited to RSS. ALL new threads are being posted as replies to old ones.
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Any addons? Try disabling them.

    I looked at the code and I don't see how this can happen unless there is some problem in the database. If the problem persists then send me admin and FTP logins and I will take a look.
  6. TheJoker

    TheJoker Member

    Yeah I have a few add-ons, but I don't believe any are causing the issue since they've been installed since I installed XenForo and have never had this problem. I'll PM you the info now. Thanks Jake.
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    It was a problem in the database. It appears that several thousand threads were deleted by manually pruning xf_thread, but the posts were left in the database. So those posts resurfaced as their thread_ids were reused.

    I increased the autoincrement value in xf_thread to be higher than the highest used thread_id. Now there is no more overlap.

    For future reference, manually deleting threads from the db usually isn't a good idea.
    Microsuck likes this.
  8. TheJoker

    TheJoker Member

    Thanks so much Jake!

Share This Page