1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Age visibility in profiles not working?

Discussion in 'Resolved Bug Reports' started by fredrikse, Jan 6, 2013.

  1. fredrikse

    fredrikse Active Member

    Hi,

    I was trying out the "date of birthday privacy" settings below:

    dob.png
    When "Show year of birth" is marked the age information is not visible in the profile:

    dob_on_profile.png

    Why?

    But when I also mark "Show day and month of birth", then the age is visible in the picture above. How come?
     
    erich37 likes this.
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    You can't know the exact age without both.
     
    fredrikse likes this.
  3. fredrikse

    fredrikse Active Member

    True (y) Didn't think that one through all the way.
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    In which case, I would suggest that the form is set up incorrectly.

    This behaviour is inconsistent with other XF form elements.

    Usually the parent checkbox would disable the child checkbox in cases where one depends on the other.
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Valid.

    Moving to bugs.
     
    erich37 and Chris D like this.
  6. Despair

    Despair Active Member

  7. Chris D

    Chris D XenForo Developer Staff Member

    An alternative fix is to resolve the age as "about X years old".

    That could be done by taking current year - birth year...

    Just a thought - not sure I like that solution, but it is an option.
     
  8. Mike

    Mike XenForo Developer Staff Member

    I've adjusted the checkbox structure to reflect the code.
     
    fredrikse and Slavik like this.

Share This Page