• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

how to disable Instant-Messenger ID to be visible in Profiles?

erich37

Well-known member
#1
How to diable registered users from seeing the "Instant Messenger" ID´s of other users?

I am thinking of either one of the following options:
- so either completely hide this information and do not let any user to enter his Instant-Messenger-ID
- have Instant-Messenger-ID only visible to certain user-group, e.g. premium members?

Appreciate your help!
 

erich37

Well-known member
#6
Erich, please check as follow:
In german: ACP->Benutzer->Webdienste anzeigen
Remove what ever you want.
thanks DSF!

So I can just delete all of those ?
I mean isn`t there anything to just "disable those" and make it visible again later again if I wish to do so?
 

erich37

Well-known member
#7
crap!
I deleted now all "Identity Services", but at a certain user-profile (user who has already entered his Yahoo-ID previously) , it shows on his profile-page:

identity_service_name_yahoo:

So instead of the wording "Yahoo Messenger ID" it now shows the code for the phrase: identity_service_name_yahoo:
How do I get rid of this as well ?

Now it is not possible to delete the data (messenger ID's) which have been entered by the user before, meaning: how to remove the messenger-ID's from the user`s profile-page, when in fact it is not possible to edit in the ACP anymore because I deleted those "identity services" ????

man, I hate this.
 

erich37

Well-known member
#10
Edit the fields on the Additional Contact tab of the user in question in the ACP.
this is not possible anymore, as I deleted all "Identity Services". So how do I go about editing the fields as those are not available in ACP any longer.
I actually just wanted to disable all "Identity Services" and also remove the already entered data from my users from public view.
 

Brogan

XenForo moderator
Staff member
#11
You could try adding the service again, editing the user profile, then removing the service again.

If that doesn't work you will more than likely need to remove it directly from the database.
 

erich37

Well-known member
#12
You could try adding the service again, editing the user profile, then removing the service again.

If that doesn't work you will more than likely need to remove it directly from the database.
yep, that works. Thanks!
However there should be an option to just hide all "Identity Services" from within ACP.
 

erich37

Well-known member
#13
BTW:

is there a way to list all members who have entered an "Identity Service" or do I need to manually go through all of my members profiles in order to find which member has left an entry within the "Identity Services"? That would be a huge workload.....