• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 after converting to xenForo...

gmaister22

Active member
#1
Hey there..

few days ago, i converted my board from IPB to xenForo and i just noticed that my Google Webmaster Tools is full of errors.

Obviously, IPB uses a different URL structure so all my URLs on google are in IPB structure...thus Webmaster Tools is giving errors...



As you can see, my main site (which is the one with www infront) has the old layout (IPB) while the non www domain has already been cached...(i of course have a 301 redirection in my .htaccess file, that is working just fine and i have set up my main domain to be the one with the www)



Any ideas what i could do? Because right now, google is indexing my site using IPB's URL structure...

Also, all graphs end on the 19th, which is when i converted to XF....what is wrong? :(
 

gmaister22

Active member
#3
I hadn't...i just did though

That's my .htaccess file
Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>
 
ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default
 
<IfModule mod_rewrite.c>
    RewriteEngine On
 
      RewriteCond %{HTTP_HOST} ^razeflux\.com$
      RewriteRule ^/?$ "http\:\/\/www\.razeflux\.com\/" [R=301,L]
 
 
    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo
 
    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
   
        # IPS Rewrite Rules
    RewriteCond %{REQUEST_URI} /(topic|forum|user)/ [OR]
    RewriteCond %{QUERY_STRING} (^|&)show(topic|forum|user)= [OR]
    RewriteCond %{QUERY_STRING} ^/(topic|forum|user)/ [OR]
    RewriteCond %{PATH_INFO} ^/(topic|forum|user)/
    RewriteRule ^.*$ ips2xf.php [NC,L]
 
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
      RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml) - [NC,L]
      RewriteRule (robots\.txt)$ robots.php [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
All the old links now are redirecting to http://www.domain.com though

is there a way i can make old urls to new urls?
 

gmaister22

Active member
#5
Did you archive the import log and follow the instructions as explained in the manual?

http://xenforo.com/help/import-redirection/
Yeap mate,

Code:
<?php
 
/* ----------------------------------------------------------- *\
This variable defines where XenForo is installed.
 
If you have not installed XenForo into the same directory in which
IP.board was installed, you will need to provide the full path to
the XenForo directory here. Remove the leading // and then enter
the path as in the following examples:
#
#    $fileDir = '/home/example/public_html/new_forums';
#
#    $fileDir = 'C:/inetpub/wwwroot/xenforo';
#
\* ----------------------------------------------------------- */
 
    $fileDir = '/home/*****/public_html';
 
/* ----------------------------------------------------------- *\
This constant defines the table from which the import redirection
scripts will fetch their data. Normally they will use the table
'xf_import_log', but if you have archived your import data, you
should provide the name of the archive table here. Remove the
leading // and then replace 'import_log_x' with the name of your
archive table, as in the following examples:
#
#    define('IMPORT_LOG_TABLE', 'my_import_log');
#
#    define('IMPORT_LOG_TABLE', 'import_log_my_forums');
#
\* ----------------------------------------------------------- */
 
    define('IMPORT_LOG_TABLE', 'archived_import_log');