admin_templates

-Calypso-

Member
I am working on a modification and it will require the use of 2 text areas in the forum_edit admin template. I edited the db with my changes but the changes are not being reflected in the AdminCP. How do we edit admin templates?
 

Brogan

XenForo moderator
Staff member
Have you enabled debug mode?

Add $config['debug'] = true; to library/config.php
 

-Calypso-

Member
Have now. In the forum_edit bit, under
Code:
	<fieldset>
		<xen:selectunit name="parent_node_id" value="{$forum.parent_node_id}" label="{xen:phrase parent_node}:">
			<xen:options source="$nodeParentOptions" />
		</xen:selectunit>
		
		<xen:textboxunit name="display_order" value="{$forum.display_order}" label="{xen:phrase display_order}:">
			<xen:explain>{xen:phrase position_of_this_item_relative_to_other_nodes_with_same_parent}</xen:explain>
		</xen:textboxunit>
		
		<xen:checkboxunit label="">
			<xen:option name="display_in_list" label="{xen:phrase display_in_node_list}" selected="{$forum.display_in_list}">
				<xen:hint>{xen:phrase if_unselected_users_will_not_see_this_node_in_list}</xen:hint>
			</xen:option>
		</xen:checkboxunit>
	</fieldset>
I added:
Code:
	<fieldset>
		<xen:textboxunit name="fimg_unread" value="{$forum.fimg_unread}" label="{xen:phrase fimg_unread}:">
			<xen:explain>{xen:phrase position_of_this_item_relative_to_other_nodes_with_same_parent}</xen:explain>
		</xen:textboxunit>
		<xen:textboxunit name="fimg_read" value="{$forum.fimg_read}" label="{xen:phrase fimg_read}:">
			<xen:explain>{xen:phrase position_of_this_item_relative_to_other_nodes_with_same_parent}</xen:explain>
		</xen:textboxunit>
	</fieldset>
then I altered the db with the new content however I see nothing being added to the forum_edit again in the ACP.

Thanks
 

-Calypso-

Member
Yes, that is usually the case with updates. Thanks for the reminder though, I'm scatter-brained so I need it. :)
 
Top