1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Admin/SuperMod has "insufficient privileges..."

Discussion in 'Troubleshooting and Problems' started by BGL, Jun 9, 2014.

  1. BGL

    BGL Well-Known Member

    I have my account and admin account.

    With my account I can log on to the Admin Control Panel. I have it set the same as the main Admin account with all permissions (everything is marked "Allow") but I get the "You have insufficient privileges".

    What am I missing?
     
  2. Amaury

    Amaury Well-Known Member

    Use the permissions analyzer to determine the issue.
     
  3. Steve F

    Steve F Well-Known Member

    Where do you receive that message? I'm assuming it is because you have not defined your user id as a Super Admin in the config.php
     
  4. BGL

    BGL Well-Known Member

    Did that but it just shows me what I see when I log in with my user account "Insufficient privileges....etc'

    I see the message in small print at bottom when I go to one of the forums/nodes. I see only my messages and the fine print at bottom that I can have insufficient privileges to post.

    How do I access the config.php?
     
    Last edited: Jun 9, 2014
  5. EQnoble

    EQnoble Well-Known Member


    FTP (or cpanel file manager) to YOUR_XENFORO_LOCATION/library/config.php
     
  6. Steve F

    Steve F Well-Known Member

    You need to check your node permissions then it seems. I thought you were talking about accessing certain areas of the ACP.
     
  7. BGL

    BGL Well-Known Member

    It was basic forum access in XenForo. The ID has admin privileges, can access the XenForo control panel but can't access the forums. It worked previously and I don't remember having to go outside of XenForo control to set up an additional admin account.

    Checked the node permissions and had to set them to "Allow" for each node individually. Its as though the ID had been reset to no access in the nodes while still having admin privileges to access the XenForo control panel.

    I'll run that and check. Thanks.
     
  8. Chris D

    Chris D XenForo Developer Staff Member

    It's incorrect to assume that just because a user can access the Admin CP, they can access the forum. That isn't accurate. The only difference between an Administrator and a normal user is that an Administrator has access to the Admin CP. And that's it. Technically, it's possible to have an Administrator that has zero access to anything in the front end, but can have access to do everything in the Admin CP.

    For all intents and purposes, while debugging this issue, you have to forget that the user is an Administrator. It's irrelevant.

    Even if the Administrator is a member of the "Administrative" user group, if you have ever used "Revoke" or "Never" when setting up permissions, regardless of who you are or what group you are in, that will override an "Allow" value in permissions.

    Using the Analyze Permissions feature that arrived in XenForo 1.2+ is the best way to debug this issue. This is NOT the same as Test Permissions.

    That is not an error message that the Permissions Analyzer will return. You enter a username, and you will get a page with two tabs. It might be easiest if you screenshot the output in both tabs and that should give us a general idea where the problem is.
     
    Amaury and Steve F like this.
  9. BGL

    BGL Well-Known Member

    Thanks. I believe every word but I had set the account up previously just via XenForo and it worked fine so I assumed the fix was also inside of XenForo.

    I'll run the Analyze Permissions and check the config.php.

    Ah...just realized I'm running 1.1.2 and need to up grade to 1.3.
     
    Last edited: Jun 10, 2014
  10. BGL

    BGL Well-Known Member

    An update. Somehow the user account had EVERTHING checked "Banned" "Not Banned" etc. It locked up everything up for the account. I unchecked everything and left it as an Admin account and it works fine.
     

Share This Page