• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not a bug Add new template modification button missing

rellek

Well-known member
#1
I was helping @Micha to upgrade his old wBB2 to XenForo and with that, we were fiddling around with some templates. While I know from betas and RCs that there should be a button to add new template mods, there is none in 1.2.0 in none of the forums I have access to. It looks like on the picture.
 

Attachments

rellek

Well-known member
#3
Okay... So this was changed then since RC1, right?

Is it right to be able to access the add new page if you know the URL when not in debug mode?
 

Mike

XenForo developer
Staff member
#4
Yes to both questions.

If you want to use TMs to edit your templates as an end user, we're not going to outright stop you - hence the direct URL access. We are going to discourage it though as the template should be edited directly instead.
 

CyberAP

Well-known member
#5
That's not the first time I see people wondering where is 'Create new modification' button. Maybe it's better to add some faint explanation there like: 'You need to enter debug mode in order to create new TM'.
 

Dynamic

Well-known member
#6
Is there any particular reason why users should not be creating template modifications and editing the templates instead? I use the Template Modifications to test things, and it is very easy being able to turn something off with a click of a button.
 

Jeremy

Well-known member
#10
It's also very easy to make a mistake when using the Template Modifications and wipe out entire templates, which can be difficult for some to debug and fix.