1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed ACP search doesn't accept 2 characters

Discussion in 'Resolved Bug Reports' started by Luxus, Dec 28, 2012.

  1. Luxus

    Luxus Well-Known Member

    Dunno if this can be called a bug, but is certainly something the XF devs have overlooked.
    I use the ACP search mainly for quick access to style properties. For example if I want to edit the body I just type "body" in the search field and immediately get results. Problem is if I want to search for the "h1" style property it doesn't work because the ACP search only accepts a minimum of 3 characters. The minimum character amount the ACP search accepts should always match the smallest amount of characters of a style property, phrase or template.
  2. Chris D

    Chris D XenForo Developer Staff Member

    You are correct.

    The limit is defined in acp_quicksearch.js.

    If you want to fix it yourself...

    Open: js/xenforo/acp_quicksearch.js

    Find: >=3

    Replace: >=2
    Jake Bunce, Adam Howard and Luxus like this.
  3. Luxus

    Luxus Well-Known Member

    That's awesome. Works like a charm now (y)
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Chris's fix confirmed.

    A 2 character search seems of limited usefulness, but the devs will decide.
    Chris D likes this.
  5. Mike

    Mike XenForo Developer Staff Member

    Well, 2 characters may come in handy and there's no real reason not too... :)
    Luxus, Chris D and Slavik like this.

Share This Page