• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 8 pages of errors just randomly appeared

Spawne32

Active member
#1
Was wondering if anyone can help me with this, not sure if this is a plugin causing this or what, but I checked my forum this morning and found this...they all seem to have various sources and different output, not sure where its coming from. Any help would be greatly appreciated as this is above my level.



ErrorException: Undefined index: is_admin - library/XenForo/Visitor.php:417
Generated By: Unknown Account, Monday at 2:00 AM
Stack Trace
#0 /home/reallyb7/public_html/library/XenForo/Visitor.php(417): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/reallyb7/...', 417, Array)
#1 /home/reallyb7/public_html/library/XenForo/Session.php(274): XenForo_Visitor::setup(1120, Array)
#2 /home/reallyb7/public_html/library/XenForo/Controller.php(291): XenForo_Session::startPublicSession(Object(Zend_Controller_Request_Http))
#3 /home/reallyb7/public_html/library/XenForo/Controller.php(304): XenForo_Controller->_setupSession('Register')
#4 /home/reallyb7/public_html/library/XenForo/FrontController.php(346): XenForo_Controller->preDispatch('Register', 'XenForo_Control...')
#5 /home/reallyb7/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#6 /home/reallyb7/public_html/index.php(13): XenForo_FrontController->run()
#7 {main}
Request State
array(3) {
["url"] => string(44) "http://www.reallybored.org/register/register"
["_GET"] => array(0) {
}
["_POST"] => array(15) {
["username"] => string(0) ""
["6f9b4d475c2f43513fce041b272af176"] => string(12) "matildahurst"
["7b965229e8259c5f3ba67a03309f0011"] => string(22) "matildahurst@rhyta.com"
["149e5a69f296fb0e5a0ced54709f0e08"] => string(9) "Waqas1358"
["86f824fe45be12dd69085660152177cb"] => string(9) "Waqas1358"
["63ee75b4c80418bc09724301f34005b8"] => string(0) ""
["e9ad92b6a9421d9f4f5a3493cbfb8d90"] => string(6) "female"
["dob_month"] => string(1) "4"
["dob_day"] => string(2) "06"
["dob_year"] => string(4) "1990"
["80f99370eb3e3f30dfe6be345ad678a6"] => string(13) "Asia/Tashkent"
["g-recaptcha-response"] => string(334) "03AHJ_Vut2ZWkIe1AM1EpVydS0G-4aahSwrtxBhsdU1M7ZUYgdVOujKPZJY035athgDCsVO8wN3JBYp1R1Lg3kQbDwY5Yf-jsEngTdtWTNomp_6OQxCReK-XHlXUlJ2ImjiQgMWK2bIQIF1pfmV1Z7FNEa2HtjOXpeoJbBV-OITGvYGjhCvhIpXY0qmQFCcHjiZS72ju9vnyla3wQoFJfUJAGbmYVBw7UnoRPrwLl4276dEjHZcgyCLvQbtvZGHTkgurJHJr1LwGM5L9yF3MIcAqsep03R3md-JyQLIklkaXCqC1UcAhOvq86MCdPkWP7fJK2iLqSSdDdc"
["agree"] => string(1) "1"
["_xfToken"] => string(8) "********"
["reg_key"] => string(32) "55f4b32f241eddff1b444867ab7a0fb5"
}
}
 

Brogan

XenForo moderator
Staff member
#2
Have you made any changes recently (Monday)?

Upgraded the forum software? Installed an add-on?

Errors of this nature don't occur randomly for no reason.
 

Spawne32

Active member
#3
I have done nothing with the forum for the past two weeks. lol You are welcome to take a look if you like, this type of error is way above my skillset. Do you want me to PM you admin credentials?
 

Brogan

XenForo moderator
Staff member
#4
Run a file health check in the ACP.

Try uploading a fresh copy of library/XenForo/Visitor.php.

Also, run this query in phpMyAdmin and post the output with full texts:
Code:
show create table xf_user;
 

Spawne32

Active member
#5
All 1,303 checked files are present and correct.

uploaded new visitor.php, both files were the same size

SQL result
Host: localhost
Database: reallyb7_xfdata
Generation Time: Feb 05, 2015 at 11:23 PM
Generated by: phpMyAdmin 4.0.10.7 / MySQL 5.6.22
SQL query: show create table xf_user;
Rows: 1


Table Create Table
xf_user CREATE TABLE `xf_user` (
`user_id` int(10) unsig...
 

Spawne32

Active member
#6
print view with full texts displays this

CREATE TABLE `xf_user` (
`user_id` int(10) unsigned NOT NULL AUTO_INCREMENT,
`username` varchar(50) NOT NULL,
`email` varchar(120) NOT NULL,
`gender` enum('','male','female') NOT NULL DEFAULT '' COMMENT 'Leave empty for ''unspecified''',
`custom_title` varchar(50) NOT NULL DEFAULT '',
`language_id` int(10) unsigned NOT NULL,
`style_id` int(10) unsigned NOT NULL COMMENT '0 = use system default',
`timezone` varchar(50) NOT NULL COMMENT 'Example: ''Europe/London''',
`visible` tinyint(3) unsigned NOT NULL DEFAULT '1' COMMENT 'Show browsing activity to others',
`user_group_id` int(10) unsigned NOT NULL,
`secondary_group_ids` varbinary(255) NOT NULL,
`display_style_group_id` int(10) unsigned NOT NULL DEFAULT '0' COMMENT 'User group ID that provides user styling',
`permission_combination_id` int(10) unsigned NOT NULL,
`message_count` int(10) unsigned NOT NULL DEFAULT '0',
`conversations_unread` smallint(5) unsigned NOT NULL DEFAULT '0',
`register_date` int(10) unsigned NOT NULL DEFAULT '0',
`last_activity` int(10) unsigned NOT NULL DEFAULT '0',
`trophy_points` int(10) unsigned NOT NULL DEFAULT '0',
`alerts_unread` smallint(5) unsigned NOT NULL DEFAULT '0',
`avatar_date` int(10) unsigned NOT NULL DEFAULT '0',
`avatar_width` smallint(5) unsigned NOT NULL DEFAULT '0',
`avatar_height` smallint(5) unsigned NOT NULL DEFAULT '0',
`gravatar` varchar(120) NOT NULL DEFAULT '' COMMENT 'If specified, this is an email address corresponding to the user''s ''Gravatar''',
`user_state` enum('valid','email_confirm','email_confirm_edit','moderated','email_bounce') NOT NULL DEFAULT 'valid',
`is_moderator` tinyint(3) unsigned NOT NULL DEFAULT '0',
`is_admin` tinyint(3) unsigned NOT NULL DEFAULT '0',
`is_banned` tinyint(3) unsigned NOT NULL DEFAULT '0',
`like_count` int(10) unsigned NOT NULL DEFAULT '0',
`warning_points` int(10) unsigned NOT NULL DEFAULT '0',
`is_staff` tinyint(3) unsigned NOT NULL DEFAULT '0',
`ignore_node` blob,
`activity_visible` tinyint(3) unsigned NOT NULL DEFAULT '1',
PRIMARY KEY (`user_id`),
UNIQUE KEY `username` (`username`),
KEY `email` (`email`),
KEY `user_state` (`user_state`),
KEY `last_activity` (`last_activity`),
KEY `message_count` (`message_count`),
KEY `trophy_points` (`trophy_points`),
KEY `like_count` (`like_count`),
KEY `register_date` (`register_date`),
KEY `staff_username` (`is_staff`,`username`)
) ENGINE=InnoDB AUTO_INCREMENT=1135 DEFAULT CHARSET=utf8
 

Brogan

XenForo moderator
Staff member
#7
That looks OK.

I just registered a test account and it seemed to go through OK.

Were there any errors generated?
If not, considering the last error was a few days ago, it could have been a temporary problem.
 

Spawne32

Active member
#8
Nothing new generated after you registered, seems to only be with a few specific accounts (from what i can read). Ill just let it go and see if anything else comes up over the next few weeks. Should I run a database repair at all?