• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 96 Pages of Errors today..

TheBoss

Well-known member
#1
I am running v1.4.6 and even though forum still seems to be working just fine I have just noticed 96 pages of errors that have just started today.

I have not added or done anything for weeks now apart from the daily checks ...

Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Incorrect key file for table './rhprojec_xen1/xf_session.MYI'; try to repair it -library/Zend/Db/Statement/Mysqli.php:214
Generated By: Unknown Account, 20 minutes ago
Stack Trace
#0 /home/rhproject/public_html/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
#1 /home/rhproject/public_html/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#2 /home/rhproject/public_html/library/Zend/Db/Adapter/Abstract.php(661): Zend_Db_Adapter_Abstract->query('DELETE FROM `xf...')
#3 /home/rhproject/public_html/library/XenForo/Session.php(827): Zend_Db_Adapter_Abstract->delete('xf_session', 'expiry_date < 1...')
#4 /home/rhproject/public_html/library/XenForo/CronEntry/CleanUp.php(23): XenForo_Session->deleteExpiredSessions()
#5 [internal function]: XenForo_CronEntry_CleanUp::runHourlyCleanUp(Array)
#6 /home/rhproject/public_html/library/XenForo/Model/Cron.php(357): call_user_func(Array, Array)
#7 /home/rhproject/public_html/library/XenForo/Deferred/Cron.php(24): XenForo_Model_Cron->runEntry(Array)
#8 /home/rhproject/public_html/library/XenForo/Model/Deferred.php(294): XenForo_Deferred_Cron->execute(Array, Array, 7.99999690056, '')
#9 /home/rhproject/public_html/library/XenForo/Model/Deferred.php(428): XenForo_Model_Deferred->runDeferred(Array, 7.99999690056, '', false)
#10 /home/rhproject/public_html/library/XenForo/Model/Deferred.php(373): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
#11 /home/rhproject/public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
#12 {main}
Request State
array(3) {
["url"] => string(35) "http://rh-project.info/deferred.php"
["_GET"] => array(0) {
}
["_POST"] => array(4) {
["_xfRequestUri"] => string(1) "/"
["_xfNoRedirect"] => string(1) "1"
["_xfToken"] => string(8) "********"
["_xfResponseType"] => string(4) "json"
}
}

Any ideas on the cause.. or cure ?

Regards..
 

Brogan

XenForo moderator
Staff member
#2
This indicates some sort of database corruption.

You should contact your host to determine what has caused it.

You can try repairing the xf_session table to resolve it.
 

TheBoss

Well-known member
#3
Going through Cron jobs.. it seems as though the Hourly Clean up is causing the problem as that throws error and fails...