1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 503 error code caused from a table error

Discussion in 'Troubleshooting and Problems' started by Tarynjh, Jul 25, 2013.

  1. Tarynjh

    Tarynjh Member

    So my site was working perfectly fine until about an hour and a half ago, where I received a 503 error. At this point in time, I was trying to receive help in another thread on here about postbit unevenness, when all of a sudden the site crashes. Since then, I've received five pages full of errors in my server error log pertaining to some table. What table? I have no idea, since I wasn't even touching anything at that point in time. My co-admin has stepped away for the next few days as he's recovering from surgery, so there's no way he was doing anything within the ACP that could've caused it.

    This is the error that shows up for 5 pages in a row:

    Code:
    Error Info
    Zend_Db_Statement_Mysqli_Exception: Mysqli prepare error: Table './deadfans_taryn/xf_session' is marked as crashed and should be repaired - library/Zend/Db/Statement/Mysqli.php:77
    Generated By: Unknown Account, 7 minutes ago
    Stack Trace
    
    #0 /home/deadfans/public_html/forum/library/Zend/Db/Statement.php(115): Zend_Db_Statement_Mysqli->_prepare('INSERT INTO `xf...')
    #1 /home/deadfans/public_html/forum/library/Zend/Db/Adapter/Mysqli.php(381): Zend_Db_Statement->__construct(Object(Zend_Db_Adapter_Mysqli), 'INSERT INTO `xf...')
    #2 /home/deadfans/public_html/forum/library/Zend/Db/Adapter/Abstract.php(478): Zend_Db_Adapter_Mysqli->prepare('INSERT INTO `xf...')
    #3 /home/deadfans/public_html/forum/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `xf...', Array)
    #4 /home/deadfans/public_html/forum/library/XenForo/Session.php(690): Zend_Db_Adapter_Abstract->insert('xf_session', Array)
    #5 /home/deadfans/public_html/forum/library/XenForo/Session.php(431): XenForo_Session->saveSessionToSource('e1244ac9fcdbb4d...', false)
    #6 /home/deadfans/public_html/forum/library/XenForo/Controller.php(403): XenForo_Session->save()
    #7 /home/deadfans/public_html/forum/library/XenForo/Controller.php(350): XenForo_Controller->updateSession(Object(XenForo_ControllerResponse_View), 'XenForo_Control...', 'Registrationreq...')
    #8 /home/deadfans/public_html/forum/library/XenForo/FrontController.php(320): XenForo_Controller->postDispatch(Object(XenForo_ControllerResponse_View), 'XenForo_Control...', 'Registrationreq...')
    #9 /home/deadfans/public_html/forum/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #10 /home/deadfans/public_html/forum/index.php(13): XenForo_FrontController->run()
    #11 {main}
    Request State
    array(3) {
      ["url"] => string(60) "http://deadfans.net/forum/index.php?threads/reedus-on-set.2/"
      ["_GET"] => array(1) {
        ["threads/reedus-on-set_2/"] => string(0) ""
      }
      ["_POST"] => array(0) {
      }
    }
    
     
  2. Tarynjh

    Tarynjh Member

    Update:

    I am about to die from laughter at the moronic robot tech support team. This guy claimed he just checked my CPU/memory usage and claim it has been exceeded. This is a screenshot taken from about 3 seconds ago, approximately:

    server.png

    Does that LOOK like I've exceeded my usage!??!!
     
  3. JulianD

    JulianD Well-Known Member

    Try to truncate your xf_session table. That should fix the error.

    Remember to backup your forum first.
     
  4. Tarynjh

    Tarynjh Member

    Forgive me for sounding stupid, but how exactly do I do that?
     
  5. Tarynjh

    Tarynjh Member

    Dear Lord, I figured it out. Thank you so much Julian!
     

Share This Page