• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 500 Internal Server Error for everything

#1
I get a 500 internal server error for pretty much anything I do. Importing a style, deleting a style, switching to a different style, disabling or enabling an add on, uninstalling an addon, trying to rebuild caches, trying to rebuild core master data, etc ,etc. Usually if I go back and refresh it appears the style was installed,changed, or the addon was disabled.

Right now i've got tag me, xenporta, and user rank ribbons installed, and there all disabled but xenporta. I'm on xenforo 1.2.1.
 
#13
Host said they fixed the problem and I'm not seeing anymore errors in the php log, but my issue continues. Seems like its different now, only some add ons give the 500 internal error when disabling/enabling them. Also some text has changed, instead of log out neokyle21 the logout button for the admin cp says log_out_x. I also have a yellow notice that says manual_rebuild_processes_have_been_stopped_before_completion. Clicking it gives a 500 internal error, trying to rebuild master data still gives a 500 internal error.
 

Mike

XenForo developer
Staff member
#14
Try adding this to then end of your library/config.php:

Code:
$config['rebuildMaxExecution'] = 5;
It looks like your host has an unreasonably low script execution limit (less than 10 seconds). This change will attempt to limit the length of some processes, but other ones can't be limited. If this change fixes the issue, I'd have to recommend that you contact the host to ask them to reduce some of the restrictions -- they're basically lower than I've seen on a host before.
 
#15
Try adding this to then end of your library/config.php:

Code:
$config['rebuildMaxExecution'] = 5;
It looks like your host has an unreasonably low script execution limit (less than 10 seconds). This change will attempt to limit the length of some processes, but other ones can't be limited. If this change fixes the issue, I'd have to recommend that you contact the host to ask them to reduce some of the restrictions -- they're basically lower than I've seen on a host before.
Thanks your fix worked, everything is back in perfect working order.