1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 404 Errors

Discussion in 'Troubleshooting and Problems' started by Storm3y, Sep 6, 2013.

  1. Storm3y

    Storm3y Member

  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    Can you view any portion of your site? It appears as if your index.php file is missing with a 404, but without knowing your URL, its hard to give a definitive answer further than what I've said.
     
  3. Storm3y

    Storm3y Member

    Hi,

    Yup it works fine when logged in.
    http://www.fffsquad.com/index.php
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    Do you have any add-ons that work on the index / home page? Can you confirm with add-ons disabled?
     
  5. Storm3y

    Storm3y Member

    Disabled Addons and tried. Still the same. :S
     
  6. Slavik

    Slavik XenForo Moderator Staff Member

    Try uncommenting this line as per the htaccess instructions.

    #RewriteBase /xenforo
     
  7. Storm3y

    Storm3y Member

    Hi, uncommenting that line hasn't had any affect.

    I changed it too RewriteBase / as our install is installed in /public_html/
     
  8. Slavik

    Slavik XenForo Moderator Staff Member

    So, what has been altered since your site was working? Any new addons, altering settings, updating server?
     
  9. Storm3y

    Storm3y Member

    I have a feeling one or two of the settings could of been updated. Possibly PHP but not entirely sure.

    We had an issue with our php.ini as what I posted in http://xenforo.com/community/threads/php-ini.58183/#post-620311

    However the site is operating perfectly fine on the system wide php.ini for logged in users, we are just having issues with guests.
     
  10. Slavik

    Slavik XenForo Moderator Staff Member

    Well, best way is to undo any changes youve made one at a time until it works again, so I guess to start, disable ioncube...
     
  11. Storm3y

    Storm3y Member

    I didn't actually make any changes that I'm aware. The system must of had auto update or something.


    But it does appear to only be effecting users that arent logged in.
     
  12. Slavik

    Slavik XenForo Moderator Staff Member

    So did you alter your php.ini or not?

    Regardless of if users are logged in or not, if the error has just started showing, then you find out what has changed, and revert it. Standard troubleshooting...
     
  13. Storm3y

    Storm3y Member

    Hi,

    I just deleted the php.ini file in /public_html to fix the internal server error.

    Adding $config['enableListeners'] = 0; to the /library/config.php file fixed the issue. Does that mean its an addon issue?
     
  14. Jeremy

    Jeremy XenForo Moderator Staff Member

    If reverting php.ini didn't fix the issue, and then disabling listeners did, yes, it is an add-on issue. You should enable them one by one until you figure out which one is causing it.
     
  15. Storm3y

    Storm3y Member

    We have quite a lot of plugins enabled. Is it possible to disable them all then start to enable one? It takes us time to uncheck the boxes and wait for it to load.
     
  16. Jeremy

    Jeremy XenForo Moderator Staff Member

    There may be a query, but I do not know it off the top of my head. You could also disable them one by one until it works based on the order you installed them. That would also tell you which one it was.
     
  17. Storm3y

    Storm3y Member

    Found the problem folks. An addon called stopbotresources.


    Thanks for your help folks :)
     
    Last edited: Sep 6, 2013

Share This Page