1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Lack of Interest 2.0 namespaces

Discussion in 'Closed Suggestions' started by Jake B., Dec 20, 2014.

  1. Jake B.

    Jake B. Well-Known Member

    Moreso just curious whether or not xf2.0 will make use of namespaces. They've been available since PHP 5.3, which just reached EOL back in August, and even PHP 5.4 will be reaching EOL in March iirc, and I'm fairly certain that most shared hosting providers are running at least 5.3 (I've run into a single instance where a forum was on 5.2.x). There really is no reason for anyone to be using under 5.4.
     
    Xon likes this.
  2. Chris D

    Chris D XenForo Developer Staff Member

    The minimum requirements for XenForo 2.0 are (at this stage) > PHP 5.3, so it's possible :)

    It's also worth noting that XenForo 1.x itself has some limited namespacing support, but we don't use it in the core code for obvious reasons.
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

    I have done many installations on PHP 5.2.x.
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    Indeed.

    It shouldn't be this way, but the adoption rate of PHP new versions is terrible:

    upload_2014-12-20_21-3-24.png

    So it certainly doesn't look likely we'd risk jumping up to 5.4...
     
  5. Martok

    Martok Well-Known Member

  6. Jake B.

    Jake B. Well-Known Member

    That's terrible, are these people usually on their own servers, or are major shared hosting providers still using 5.2.x?

    I believe namespace support came in with 5.3, didn't it?
     
  7. Chris D

    Chris D XenForo Developer Staff Member

    Yeah. The quote wasn't related to namespaces. Was just a general comment based on the adoption of PHP 5.4 vs 5.3.
     
  8. Robust

    Robust Well-Known Member

    I think you should. Hosting providers should be up to date (shared hosting, that is), at least to 5.4.x, and if they aren't you should really be looking for a new host. A VPS is priced just as much as a shared hosting package from some reliable providers, RamNode sells them dirt cheap and they're pretty damn good there. If software isn't pushing these providers to be using 5.4.x or higher, they won't ever feel the need to be upgrading. With enough complaints, they should upgrade, but again, any reliable hosting provider shouldn't be at 5.3.x or below. If people find no necessity to be using a higher version, they won't bother.
     
  9. Tracy Perry

    Tracy Perry Well-Known Member

    In a perfect world they would update regularly... but we don't live in a perfect world. Depending on how large their infrastructure is, they may not want to invest in the time to upgrade. Not to mention the fact that they probably have customers that are running scripts that won't work with the more recent versions of PHP (if I'm not mistaken, I think the vBulletin 3.x series has problems with 5.4 of PHP - I think 3.8.8 will work with 5.4 but anything below that has to use 5.3 of PHP.). When you have companies with the attitude of EIG running so many hosting providers, you should realize that their main concern is money - not security.
    Now, as for VPS's - not everybody is techinically competent to run their own server or they don't want the headaches associated with it.
     
  10. BamaStangGuy

    BamaStangGuy Well-Known Member

    People are still using vBulletin 3. If people want 5.2 or 5.3 support they can continue to use XenForo 1.4. 2.0 needs to get out of the 2000's and stop hanging out with most of the other ancient forum software out there.
     
    RobinHood, Apiweb, Erel and 5 others like this.
  11. Robust

    Robust Well-Known Member

    They won't have to upgrade if every software is scared to up their requirements. They upgrade when their customers want it. And you're forgetting that large scale hosts don't ssh into every server manually to do work. They have one mainframe to do it probably, from free solutions such as SaltStalk to enterprise solutions. Give some notice to customers and upgrade. Easy. Hell if they really want open a support request for anyone using 5.3.x still and there will be 5.3.x nodes available for customers who ask for it specifically. Honestly, 2014, a VPS is almost as cheap as shared hosting, as many websites as you like, we shouldn't even be using shared hosting if we're using premium software like XenForo. The only thing I'd put on shared hosting is something I don't care about... at all. If people want to use it, they can email, they can ring and complain to their hosts, and if the host knows one thing about customer satisfaction they'll take care of it. If they don't, you just identified a terrible host.

    Following a post by Kier, when we worked for vBulletin, vBulletin reached its EOL ages ago. If anyone is still stuck like 9 years in the part with ancient forum software, that's not a valid reason to not bump up for 2.0. Another post for the EOL of other branches of v3. v3 isn't even on their website anymore, why are we worrying about forum software that people should have moved on from. I mean, what percentage of forums are vB 3 that you see every day? If people keep worrying about other forum software that was released something like 10+ years ago and dead since 6+ years we are never going to get past PHP 5.3. I'm afraid to say if we continue to think like that we'll hit 2020 and hopefully make it to PHP 5.4. 2.0 is that major upgrade we've all been waiting for, changes from the ground up, why on earth should we be limiting developers t0 the tools provided by PHP 5.3. It really makes no sense.
     
    Last edited: Dec 26, 2014
  12. Tracy Perry

    Tracy Perry Well-Known Member

    Of the 3 motorcycle forums I regularly participate on... 100% of them are.
    Some folks like vB.. and if 3.x series is working for them they don't want to have to upgrade, especially if they are severely customized with bespoke add-ons.
    You want to pay for all those folks to upgrade? :p
    Some of them don't have the money to but want to continue running their forum so they stick with what they have that works.

    You are talking now about developers.. who are NOT the hosting providers. The hosting providers still have to provide to the LCD to maximize their profits.
    The developers can do what they want and then have the purchaser go to their own hosting provider. The point is that as long as there are people running vB 3.x series, you are going to have the OLD versions of PHP out there.
    That's why I'm on my own hardware - I can control it. BUT not everybody is capable of that and not everybody is going to go pay the price for a "performance" host provider. I can't tell you the number of times I've seen in this very support site folks buying XenForo and then asking about the cheapest hosting they can get to run it on.
     
  13. Robust

    Robust Well-Known Member

    You can bet it won't take long for a decent host to update their requirements, again, if we are so concerned that shared hosting providers will be too lazy to update their PHP, we'll get nowhere. A host wants money right, and they're lazy, they don't want to pay people to update their PHP, maximise profits? They won't have any customers if they can't support the latest technology. And a lot of shared hosts do/are starting to push to 5.4. Example: HostGator. I hate them personally, but they're huge. That post shows them adopting PHP 5.4. The world is changing. PHP don't push updates out for no reason.
     
  14. BamaStangGuy

    BamaStangGuy Well-Known Member

    Treat them like your ISP. They could give you 1 gbps internet but they won't because there isn't any incentive to do so. The most popular php scripts in the world still support 5.2. Take https://wordpress.org/about/requirements/ for example. Until they have a reason to, they won't.
     
  15. Chris D

    Chris D XenForo Developer Staff Member

    Forgetting the PHP adoption argument, if there is reasonable justification to increase the requirements, then we will. At the moment, there isn't. If we need to do something in the code that pushes XF forward, that we can't do in PHP 5.3, then it will be considered.
     
  16. Tracy Perry

    Tracy Perry Well-Known Member

    My point is that YES it costs them money to update to the latest greatest as they have to roll it out on thousands of servers, and they have to EXTENSIVELY test it prior to doing it. Folks like those with the EIG group are more interested in the money on the here and now and not down the road.
    And when I was with them it was like pulling teeth to get them to 5.3. And that was 2 years ago. Please don't use HostGator as an example of someone adopting it quickly. Like I said, 2 years later and they are just now pushing out 5.4, and we are on 5.6.

    Do I think that all should be on at least 5.4 and preferably 5.5 or 5.6? Yes - but I'm realistic and know from a business perspective that's not going to happen.
     
  17. Snog

    Snog Well-Known Member

    The problem with hosts upgrading to the latest/greatest PHP version has two sides to it. The host side has been mentioned extensively here, but the client side hasn't been mentioned at all.

    Hosts that upgrade can have their client's sites crash because of what were once depreciated functions being obsolete/removed in the latest PHP version. This could lose more clients than the upgrade would bring in new clients. I would bet there are some hosts that have a number of servers reserved to run older versions of PHP where required.
     
  18. tyteen4a03

    tyteen4a03 Well-Known Member

    Many cPanel hosts have already introduced PHP version switching (and holy hell, even extensions). If some want to stay behind in the dust they can do so, but others have the option to upgrade to the latest version.

    I want 5.4 because I like the syntactic sugar they've added. I hate having to instantiate an array with array() when in Python it's just [] or {}, and the use of temporary variables when accessing a return array when you can just do foo()[0].
     
    RobinHood, Luke F and Xon like this.
  19. Daniel Hood

    Daniel Hood Well-Known Member

    While I appreciate these examples (and actually use them in other projects that I require 5.4 in), that's not enough to completely ignore all the market share that is on 5.3. In my opinion at least.
     
    SneakyDave likes this.
  20. Jake B.

    Jake B. Well-Known Member

    I definitely agree that they should be. However by the default yum repositories on CentOS 6.6 only contain PHP 5.3.3, and many people who run their own server don't seem to know how to get later versions, or even install the software from it's source.
     

Share This Page