• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed 1.4 - Incorrect HTML in helper_poll_create template

John L.

Well-known member
#1
Just a quick note, some incorrect HTML in the helper_poll_create template:
HTML:
<!-- slot: after_poll_responses -->
<dl class="ctrlUnit">
    <dt>{xen:phrase maximum_selectable_responses}:</dt>
    <dd>
        <ul>
            <li><label><input type="radio" name="poll[max_votes_type]" value="single" checked="checked" /> {xen:phrase single_choice}</label></li>
            <li><label><input type="radio" name="poll[max_votes_type]" value="unlimited" /> {xen:phrase unlimited}</label></li>
            <li><input type="radio" name="poll[max_votes_type]" value="number" class="Disabler" id="ctrl_max_votes_type_value" />
                <span id="ctrl_max_votes_type_value_Disabler">
                    <input type="number" class="textCtrl number SpinBox" name="poll[max_votes_value]" value="2" min="1" step="1" />
                </span>
            </ul>
        </ul>
        <p class="explain">{xen:phrase this_is_maximum_number_responses_voter_may_select}</p>
    </dd>
</dl>
Should be:
HTML:
<!-- slot: after_poll_responses -->
<dl class="ctrlUnit">
    <dt>{xen:phrase maximum_selectable_responses}:</dt>
    <dd>
        <ul>
            <li><label><input type="radio" name="poll[max_votes_type]" value="single" checked="checked" /> {xen:phrase single_choice}</label></li>
            <li><label><input type="radio" name="poll[max_votes_type]" value="unlimited" /> {xen:phrase unlimited}</label></li>
            <li><input type="radio" name="poll[max_votes_type]" value="number" class="Disabler" id="ctrl_max_votes_type_value" />
                <span id="ctrl_max_votes_type_value_Disabler">
                    <input type="number" class="textCtrl number SpinBox" name="poll[max_votes_value]" value="2" min="1" step="1" /></span></li>
        </ul>
        <p class="explain">{xen:phrase this_is_maximum_number_responses_voter_may_select}</p>
    </dd>
</dl>
Someone put an addition close tag to the <UL> as opposed to the <LI>. Just figured I would bring it to your attention! Noticed it while adding compatibility to our addon.