1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed [1.2] Drag&Drop images

Discussion in 'Resolved Bug Reports' started by TsuChi, Jun 3, 2013.

  1. TsuChi

    TsuChi Member

    is not working properly
    I can't find a reason, but for me it just does not work in all browsers (Chrome, FF, IE10) - it gives the same effect everywhere

    What I do:
    1.I drag and drop image of my profile to the replay editor
    2. It loads into the editor.
    3.I delete it from the editor
    4.I try to do the same once again and this time nothing happens (dropping image does not work)

    Reloading the page/logo out/ closing the tab with XF does not help.
    After some random period of time I can drag and drop images again, but once the problem occurs again I am unable to do it for some random period of time.

    I was unable to find any pattern in it.

    here is a screen when I am unable to drop image into the post (always)
     

    Attached Files:

  2. Brogan

    Brogan XenForo Moderator Staff Member

    The drag and drop is for files from your PC.
    Is that what you are doing?
     
  3. mauzao9

    mauzao9 Well-Known Member

    For our PC? In the editor thread i was testing dragging your avatar into the editor, it uploaded it and from sudden that upload bar gone away. EDIT: It wasn't by dragging, i copy/pasted, oups.

    Also the images are very buggy, i pasted an image in the editor, trying to center it, it centers the whole post, I don't understand why we can't select images, neither it is possible to add a link to them (only editing in the BBCODE).
     
  4. Mike

    Mike XenForo Developer Staff Member

    This may be because our drag/drop implementation is triggering when dragging stuff other than local files. That's the only thing it should apply to. I've adjusted it to do that.

    Will be rolled out here soon.
     
    Jeremy, mauzao9 and Brogan like this.
  5. SonicRC

    SonicRC Well-Known Member

    hmm I see it works fine with chrome, but now it doesn't work with safari at all.
     
  6. Andrej

    Andrej Well-Known Member

    @Mike

    Seems like it is broken. When I try to drag and drop it gives me this instead: file://localhost/Users/andrej/Desktop/Снимок%20экрана%202013-06-03%20в%2018.28.50.png (for example)
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    I have moved the thread back to bug reports so @Mike doesn't miss it.
     
    Last edited: Jun 3, 2013
    SonicRC and Andrej like this.
  8. mauzao9

    mauzao9 Well-Known Member

    @Mike D who's the guy? I had trouble tagging, did the @ and wrote but the list didn't show up. After F5 it worked.
     
  9. Jeremy

    Jeremy XenForo Moderator Staff Member

    mauzao9 likes this.
  10. TsuChi

    TsuChi Member

    I drag an image from the XF page
     
  11. Jeremy

    Jeremy XenForo Moderator Staff Member

    @TsuChi, it should only be working on local files (not being dragged from a thread:
    Or that's how that above post makes it sound.
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    Yes, you need to drag it from Windows Explorer or the Mac equivalent.
     
  13. Mike

    Mike XenForo Developer Staff Member

    Fixed again.
     
  14. TsuChi

    TsuChi Member

    @King Kovifor yes, I understand
    but for me drag and drop means that I can simply put an image from any source to the post with a mouse
    If it works only from the PC (hard drive) it will lose its appeal to me.
    Dropping an image from pc means to me (almost 99% of the time): I have to save an image from a page I visited on my pc, then find it on my pc and drag it to the post.
    If it worked my way, I would just drag the image from any web page directly into the post.
     
  15. Brogan

    Brogan XenForo Moderator Staff Member

    That functonality is not supported.

    It is local files only, as already stated.
     
    Bob likes this.
  16. TsuChi

    TsuChi Member

    @Brogan I wish it worked that way but I understand that you (designers) have its reasons to code it this way.

    After all it is better to have any drag and drop than no drag and drop at all :)
     
  17. Mike

    Mike XenForo Developer Staff Member

    [​IMG] I just dragged Brogan's avatar in.
     
    TsuChi likes this.
  18. Mike

    Mike XenForo Developer Staff Member

    It doesn't upload the file though - it's just a link to the image.

    I just dragged Brogan's avatar in

    ^-- and that's the text.
     
    ibnesayeed likes this.
  19. TsuChi

    TsuChi Member

    Here is another tiny bug with drag and drop (from PC ;) )



    1.drag an image from PC into the post (but do not release mouse button)

    2.drag an image outside the editor (do not release the button)

    3.drag an image into the post and release the mouse



    the image won't be uploaded

    false alarm
     
    Last edited: Jun 3, 2013
  20. Jeremy

    Jeremy XenForo Moderator Staff Member

    I cannot replicate that issue on here.
     

Share This Page