• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed 1.1 b2 - iPhone - Alerts tab now needs two taps instead of one to open

CTXMedia

Formerly CyclingTribe
#3
Yes does it here too - however I've recently upgraded the phone to iOS 5 so that may be the culprit.

Perhaps another iOS 5 user could confirm?

Cheers,
Shaun :D
 

Jeremy

Well-known member
#4
I'm getting it on one tap. Your probably experiencing data delays, because I've seen it happen when data is slow for me.
 

Kier

XenForo Developer
Staff member
#5
If the menu can't be fully displayed it sometimes hides itself on iOS. Try zooming out slightly so that it will completely fit on screen when it opens.
 

CTXMedia

Formerly CyclingTribe
#6
If the menu can't be fully displayed it sometimes hides itself on iOS. Try zooming out slightly so that it will completely fit on screen when it opens.
Nope. Sorry. No dice. Does it here at XF, and at my 1.1 beta test site. Zoomed-in or out doesn't seem to matter.

It sort of splits the process into two stages:

1) Tap alert link - get the ajax animation to show it's querying - link goes into "hover" style - and then it stops there.
2) Tap again and URL bar briefly pops down and folds away - then alerts listbox displays

Seems to do this for inbox too.

I can live with it if it's just me, but I thought I'd mention it in case it was affecting other people too.

Cheers,
Shaun :D
 

CTXMedia

Formerly CyclingTribe
#7
Now I'm home I can confirm it does it over Wi-Fi as well as 3G.

I don't see the issue on my 1.0.4 board (with Flexile) though?
 

jadmperry

Well-known member
#9
I have this same problem. I updated to iOS5 yesterday and first noticed this earlier today. I just re-checked and it has the same problem.
 

Reeve of Shinra

Well-known member
#16
I'm on an iphone 4S with IOS5 --- if I have an alert, it seems to work on 1 click.

If I do not have any new alerts and click on the link it will start to open then it seems to time out. If I click on it a second time, it seems to open okay.

Seems to happen regardless of the zoom in the upright position. Trying it out in landscape seems to be okay at various zoom levels.
 

trilogy33

Well-known member
#17
All ok here on iPhone 4S under iOS 5
With or without alerts being present, a single on the tab click pulls the dropdown ok, a further click on the tab opens the alerts in full.
 
F

Floris

Guest
#18
iPad 2, iOS 5.0, Safari with and without using tabs, clicking on xenforo.com / xenfans.com on a new alert, the alert dropsdown and i can click on an item and it loads. It doesn't seem to require two clicks.
Clicking twice loads the full alerts page.
 

digitalpoint

Well-known member
#19
Seems to work fine for me (with or without new alerts). Single click opened the menu every time (checked on iPhone 4 and iPad 2, both running iOS5).

For those having issues, maybe kick Safari into developer mode (under settings) and see if some JS error is happening that is killing JS execution?
 

CTXMedia

Formerly CyclingTribe
#20
Done.

Initial log stops with 1 entry which mentions line 606 - but can't copy or paste anything from iPhone, so don't know whether it's a normal code report or an actual error?

Cheers,
Shaun :D