1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 1.1.4 Upgrade Error

Discussion in 'Installation, Upgrade, and Import Support' started by DBA, Mar 29, 2013.

  1. DBA

    DBA Well-Known Member

    Didn't find this error anywhere else on the forum, any ideas?

    Code:
    Server Error
     
    Undefined index: allo
     
    XenForo_Application::handlePhpError() in XenForo/Model/Permission.php at line 1818
    XenForo_Model_Permission->_getMergedPermissionPriorityValue() in XenForo/Model/Permission.php at line 1793
    XenForo_Model_Permission->_getPermissionPriorityValueFromList() in XenForo/Model/Permission.php at line 1680
    XenForo_Model_Permission->buildPermissionCacheForCombination() in XenForo/Model/Permission.php at line 1505
    XenForo_Model_Permission->rebuildPermissionCombination() in XenForo/Model/Permission.php at line 1453
    XenForo_Model_Permission->rebuildPermissionCache() in XenForo/CacheRebuilder/Permission.php at line 33
    XenForo_CacheRebuilder_Permission->rebuild() in XenForo/ControllerHelper/CacheRebuild.php at line 26
    XenForo_ControllerHelper_CacheRebuild->rebuildCache() in XenForo/Install/Controller/Upgrade.php at line 232
    XenForo_Install_Controller_Upgrade->actionRebuild() in XenForo/FrontController.php at line 310
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    XenForo_FrontController->run() in /var/www/vhosts/xxxxxxxxxx.com/httpdocs/install/index.php at line 18
     
  2. DBA

    DBA Well-Known Member

    Just to add I have all plugin's disabled via the config and also ran a file health check (everything check out).
     
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    allo? That looks like "allow" misspelled. Perhaps an invalid permission value somewhere. I can take a look if you give me access to phpmyadmin and admin access to the forum (for the upgrade).
     
  4. DBA

    DBA Well-Known Member

    Thanks Jake! Give me a sec to get the test admin account setup. (y)
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    FYI for others. This problem is apparently specific to his test server. The permission values are all correct in the database but they are wrong during execution. I saw cases where the last letter was truncated from both 'allow' and 'reset'. This could be a PHP problem, or maybe a problem with the MySQL connector. I didn't pinpoint it since it was discovered that his live server wasn't afflicted with this problem.
     
    DBA and Dodgeboard like this.

Share This Page