1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 1.1->1.2 Templates Problem

Discussion in 'Installation, Upgrade, and Import Support' started by Vince Taglia, Jan 31, 2014.

  1. Vince Taglia

    Vince Taglia Member

    So I had some custom templates. They were pretty basic. 1 was removing a page in the link bar. Another removed RSS feed buttons. I do not really care if I get them back or not. I just want to fix this error:

    Code:
    Server Error
    
    Mysqli prepare error: Unknown column 'template_map.template_final' in 'field list'
    
    Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    Zend_Db_Adapter_Abstract->query() in XenForo/Model.php at line 219
    XenForo_Model->fetchAllKeyed() in TMS/Model/Template.php at line 228
    TMS_Model_Template->fetchAllKeyed() in XenForo/Model/Template.php at line 431
    XenForo_Model_Template->getOutdatedTemplates() in XenForo/ControllerAdmin/Home.php at line 28
    XenForo_ControllerAdmin_Home->actionIndex() in XenForo/FrontController.php at line 347
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in MYWEBHOST/forums/admin.php at line 13
    I checked and there are no template modifications in the new version I just upgraded to (I know I should have done it sooner). Any ideas? I currently cannot open my forums. When I click it redirects to home page. I do have it re-routed and the re-route is correct.
     
  2. oman

    oman Well-Known Member

    1.2 introduced a template modification system. It clashes in some ways with the following add on - http://xenforo.com/community/resources/template-modification-system-tms.293/

    I would suggest first uninstalling that add on as it is mentioned in the error above.

    Once uninstalled, if it occurs again something else might be causing it.
     
  3. Mike

    Mike XenForo Developer Staff Member

  4. Vince Taglia

    Vince Taglia Member

    Thanks guys. Fixed. Forums weren't working because of friendly URLs
     

Share This Page