• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Unknown column 'template_map.template_final' in 'field list'

Zephyr

Well-known member
#1
Hello, I have update my version on xenforo and now I have this error when I try to access to my admin panel:

An exception occurred: Mysqli prepare error: Unknown column 'template_map.template_final' in 'field list' in /home/kyna/multigamingfrance/library/Zend/Db/Statement/Mysqli.php on line 77
  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in XenForo/Model.php at line 219
  5. XenForo_Model->fetchAllKeyed() in TMS/Model/Template.php at line 228
  6. TMS_Model_Template->fetchAllKeyed() in XenForo/Model/Template.php at line 433
  7. XenForo_Model_Template->getOutdatedTemplates() in XenForo/ControllerAdmin/Home.php at line 28
  8. XenForo_ControllerAdmin_Home->actionIndex() in XenForo/FrontController.php at line 347
  9. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  10. XenForo_FrontController->run() in /home/kyna/multigamingfrance/admin.php at line 13

How I can fix this error please ? I have try to call http://multigamingfrance.com/install/index.php?upgrade/ to rebuild all master data but don't fix the problem.
 

borbole

Well-known member
#2
Hello, I have update my version on xenforo and now I have this error when I try to access to my admin panel:

An exception occurred: Mysqli prepare error: Unknown column 'template_map.template_final' in 'field list' in /home/kyna/multigamingfrance/library/Zend/Db/Statement/Mysqli.php on line 77
  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in XenForo/Model.php at line 219
  5. XenForo_Model->fetchAllKeyed() in TMS/Model/Template.php at line 228
  6. TMS_Model_Template->fetchAllKeyed() in XenForo/Model/Template.php at line 433
  7. XenForo_Model_Template->getOutdatedTemplates() in XenForo/ControllerAdmin/Home.php at line 28
  8. XenForo_ControllerAdmin_Home->actionIndex() in XenForo/FrontController.php at line 347
  9. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  10. XenForo_FrontController->run() in /home/kyna/multigamingfrance/admin.php at line 13

How I can fix this error please ? I have try to call http://multigamingfrance.com/install/index.php?upgrade/ to rebuild all master data but don't fix the problem.
From what I have seen, the TMS add on is causing that. For more have a look here:

http://xenforo.com/community/threads/template-modification-system-tms.27973/page-30#post-592896

Uninstall that mod and see if that would help.
 

Zephyr

Well-known member
#3
Thank you, but I can't uninstall TMS, I can't enter inside my admin panel, I have this error, it's possible to disable an addon from the database please ?
 

borbole

Well-known member
#4
Enter the following code to the config.php file:

PHP:
$config['enableListeners'] = false;
This will disable all add ons. Enter your pc, uninstall the offending add on and then remove that line from the config.php file, or comment it out.
 

Zephyr

Well-known member
#5
Thank you, it's ok now, but I have an another error now on all styles and with all addon disabled (same after all master style rebuild) on all browser:




And now my youtube iframe is black:
 
Last edited:

Tracy Perry

Well-known member
#6
Thank you, it's ok now, but I have an another error now on all styles and with all addon disabled (same after all master style rebuild) on all browser:
What did you upgrade from/to. If from 1.2 or earlier to 1.4.x series - You did read the upgrade guide(s) correct?
There were a lot of add-ons that were not compatible and style issues due to template changes.

For 1.2 to 1.3, this is the biggie

https://xenforo.com/community/resources/how-to-upgrade-to-xenforo-1-3.2810/