1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 1.1.0 to 1.1.1 without upgrading

Discussion in 'Installation, Upgrade, and Import Support' started by trilogy33, Dec 30, 2011.

  1. trilogy33

    trilogy33 Well-Known Member

    Localhost tested the other day.
    Started with 1.1.0 files and db, grabbed the new 1.1.1 files and put them in place.
    Went to the forum screen expecting to be asked to "Upgrade" and it didn't ask anything. :unsure:
    Curiously going into the ACP, sure enough XenForo 1.1.1 is showing and File Health is reporting fine.
    So, without doing the upgrade process suddenly the localhost is now on 1.1.1
    Odd.
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Try going directly to /install

    If it still doesn't give you the option to upgrade to 1.1.1 then you must not have uploaded the files correctly.
     
    trilogy33 likes this.
  3. trilogy33

    trilogy33 Well-Known Member

    Cheers Jake and Happy New Year to you :)
    It's 100% sweet now, today, from a newly rebuilt set of more recent backup files.

    Previously: Went to /install but still no joy, "No Upgrade Available".
    Couldn't understand it at the time. I'd always overwritten old files via copy/paste, merge? yes - in this fashion hundreds of times before on XAMPP test and it'd worked flawlessly. So, a bit bemused.
    Anyways, sorted and thanks again.
    Verdict: (Windows) Voodoo. :cautious:
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    If you have more than one local installation then it could have been a caching issue.

    Just uploading the files won't cause the software to be automatically upgraded.

    I have several local installations, for testing and support purposes, so I have added this to the config.php of each one:
    Code:
    $config['cookie'] = array(
    'prefix' => 'xflocal_',
    'path' => '/',
    'domain' => ''
    );
    The prefix is different for all, avoiding any cookie/caching issues.
     
    quangphuc91 and trilogy33 like this.
  5. trilogy33

    trilogy33 Well-Known Member

    Thanks Brogan, Happy New Year and thanks for all the hard work and help you've put in. :)
    Just the one local test install here, so racking my mind to work out why things went weird.
    I'll keep in mind the caching angle there for future installs, you've raised a good point which may/*could* be blissfully overlooked.
     

Share This Page