1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Issues with upgrading from 1.3.5 to 1.5.8

Discussion in 'Installation, Upgrade, and Import Support' started by kkarki, May 30, 2016.

  1. kkarki

    kkarki Member

    I've downloaded the upgrade package and followed standard upgrade process. All goes OK. Upgrade went fine, I also tested couple of pages in front-end. Suddenly, after couple of hours I get following in front-end.

    "The board is currently being upgraded. Please check back later."

    Why? I've already upgraded why again this message? On admin side it shows following.

    "The board is currently waiting to be upgraded. Please Complete the upgrade."

    Clicking on that, again starts upgrade, goes everything fine. Everything OK.

    Again, after couple of hours same issue :-( you need to upgrade. I'm in the loop :(
  2. wang

    wang Well-Known Member

    Can you download the full 1.5.8 package and overwrite all your forum files again?

    But I have to admit, that it is a strange behavior. Perhaps your host is doing a restore of the files, which happen to be from the time before the upgrade was performed?
  3. kkarki

    kkarki Member

    Thanks @wang, In fact, I'm doing it in my local setup. So, there's no chance of file replacement.

    Also, during my debug, I found that following condition is not true in library/XenForo/ControllerAdmin/Abstract.php.

    if (XenForo_Application::$versionId != XenForo_Application::get('options')->currentVersionId)

    When I'm echoing values it shows like:

    XenForo_Application::$versionId => 1050870 => OK
    XenForo_Application::get('options')->currentVersionId => 1030570 => NOT OK

    I'm not sure whey XenForo_Application::get('options')->currentVersionId pointing out to old value 1030570. Is there some cache of options?

    I checked in the database that xf_option table has correct value for "currentVersionId" value.

    No clues :( what so ever why it fetches old value even though db has proper value.
  4. Mike

    Mike XenForo Developer Staff Member

    Have you defined any caching layers in config.php?
  5. kkarki

    kkarki Member

    @Mike, this is my config.php

    $config['db']['host'] = 'localhost';
    $config['db']['port'] = '3306';
    $config['db']['username'] = 'root';
    $config['db']['password'] = 'root';
    $config['db']['dbname'] = 'xenforo';

    $config['superAdmins'] = '1';

    $config['cache']['cacheSessions'] = true;
    $config['cache']['enabled'] = true;
    $config['cache']['frontend'] = 'Core';
    $config['cache']['frontendOptions'] = array(
    'caching' => true,
    'automatic_serialization' => true,
    'lifetime' => 10800,
    'cache_id_prefix' => 'XenForo'

    //$config['cache']['backend'] = 'WinCache';
    $config['cache']['backend'] = 'File';

    $config['cookie'] = array(
    'prefix' => 'xf_',
    'path' => '/',
    'domain' => 'local.xenforo'
  6. Mike

    Mike XenForo Developer Staff Member

    Your cache is almost certainly the problem, particularly if you have 2 installations. I'm guessing one of them isn't upgraded but they're both pointing to the same cache.

    TBH, as a local test board, I'd just not use a cache as specified in config.php. If you are going to use one, I wouldn't really recommend the file cache. You'll want to use a memory-backed cache.
  7. kkarki

    kkarki Member

    @Mike, many thanks, that helped.

    Changing the value of following:

    $config['cache']['enabled'] = false;

    It works.

    I would appreciate if you could point me what is the location of "File" cache? Since, I tried to search the version string on my whole project code, I didn't find it anywhere.
  8. Mike

    Mike XenForo Developer Staff Member

    Since you haven't specified a particular path, it's coming from one of a number of possible temporary directories, which may vary by OS configuration so it's hard for me to say specifically. See Zend_Cache_Backend::getTmpDir for details.
  9. kkarki

    kkarki Member

    @Mike, omg :) It was /tmp as I'm using linux.

    I would admit that I've learned something cool today in Xenforo :)

    Thanks again!

Share This Page