1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1.0.2 upgrade, Error and timeout

Discussion in 'Installation, Upgrade, and Import Support' started by Merijn, May 26, 2011.

  1. Merijn

    Merijn Member

    I keep posting threads today. So I tried upgrading to 1.0.2. Uploaded the files and went to /upload. After a couple of minute rebuilding I get this error:

    An error occurred or the request was stopped.

    And then I get to a nginx page which tells me that there was a gateway timeout. All good and well, but then when I try to access the forum it still tells me that there is an upgrade going on, and when I try to access the access panel it tells me to press the upgrade button and it starts all over again. I tried it twice now, what do I do?

    EDIT: I editted a timeout in the nginx.conf from 65 to 130. Maybe that helps.
  2. Mike

    Mike XenForo Developer Staff Member

    Do you know what step it was on when you got the error? (What it said just before it switched to that error message.)

    Unfortunately, you'll have to get through those rebuilds/updates to complete the upgrade. You can keep trying without any significant issues though.
  3. Merijn

    Merijn Member

    After a long time of 'rebuilding phrases'. I got two language packs (English and Dutch), could it be that because of that it takes longer and the installer prepared for upgrading two language packs?

    EDIT: After the importing of the Phrases it hangs on a timeout, not the importing itself
  4. Mike

    Mike XenForo Developer Staff Member

    Presumably it was the first step of that process, as the other steps will be split into 10 second chunks. You would've gotten through this process successfully in the past, so unless it was just on the cusp of failing before, you should be able to get through it.

    Are you running a VPS? The cache rebuilds are very I/O intensive, and we have seen some VPS's with really shocking write performance. (10% the speed of what I see on my desktop, for example.) It's a tricky problem to solve.
  5. Merijn

    Merijn Member

    Yes, I'm indeed on a VPS but I doubt IO is the problem. I share the disks with only 3 users, and iotop shows me that mysql is continuesly busy with writing abou 30K/s to the disk, with spikes like 3M/s.

    Setting the timeouts to a higer value appears not to work. I switched back to apache just now for just the install, let's see if that works.
  6. Merijn

    Merijn Member

    Apache has the same, BUT has a 'Rebuild Caches' button which continues the process. Yes, it still takes too long pn apache so it times out, but I just look at iotop until the mysqld isn't busy anymore and push that button. Nginx appearently just shows an timeout and refuses to go on.

    So this makes it a nginx-related problem for going to it's own page instead of showing that button?

    It managed to do the upgrade with apache just fine, and after it I switched back to my beloved nginx. :)
  7. Mike

    Mike XenForo Developer Staff Member

    Actually, it's supposed to automatically go to the next page (with a non-AJAX request, which gives it more chance of working), so I'm not sure why that didn't happen.

    I guess with nginx, it killed PHP after a certain amount of time, whereas with Apache it ran to completion. It really shouldn't be taking that long, even with 2 languages. I'm not sure if I can find a way to improve the speed.
  8. Merijn

    Merijn Member

    Is it the php-fpm that doesn't like waiting? I did put every timeout I could find trice the amount it was, but it didn't work. I'm glad it just works again, and I need to buy a dedi soon ._.
    Marcos Previato likes this.
  9. Basically, I have the same problem, and this is preventing me from running the addons, etc ...

    My phrases do not appear, and can no longer access the panel adm!

    I would like a solution, because I like crazy trying to solve!
  10. Moi EtOuir

    Moi EtOuir New Member

    Can anyone help ? I get the exact same problem as you guys.

    Is there anyway to solve this without asking the host ? (or maybe fix the script :p)
  11. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I will offer to take a look if you are comfortable giving me your FTP and admin login.

Share This Page