your fave app to convert .avi to ipod videos

pk698

Active member
#6
handbrake says I need .net version 2 or something. I installed V.4, but it still asks for it. Do I need to be French?
 
Top