1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 XML error upgrade to 1.4

Discussion in 'Installation, Upgrade, and Import Support' started by Beermonster, Dec 17, 2013.

  1. Beermonster

    Beermonster Member

    I get this error and now I can't use my site :(

    Server Error
    String could not be parsed as XML

    1. SimpleXMLElement->__construct() in XenForo/Model/AdminNavigation.php at line 0
    2. XenForo_Model_AdminNavigation->importAdminNavigationDevelopmentXml() in XenForo/Deferred/ImportMasterData.php at line 16
    3. XenForo_Deferred_ImportMasterData->execute() in XenForo/Deferred/Atomic.php at line 61
    4. XenForo_Deferred_Atomic->execute() in XenForo/Model/Deferred.php at line 252
    5. XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 378
    6. XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 312
    7. XenForo_Model_Deferred->runByUniqueKey() in XenForo/Install/Controller/Abstract.php at line 34
    8. XenForo_Install_Controller_Abstract->_manualDeferredRunner() in XenForo/Install/Controller/Upgrade.php at line 216
    9. XenForo_Install_Controller_Upgrade->actionRunDeferred() in XenForo/FrontController.php at line 347
    10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    11. XenForo_FrontController->run() in /var/www/vhosts/xxxxx./httpdocs/install/index.php at line 18
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Try uploading the files once again.
    If it still occurs, use another FTP program.
    I recommend WinSCP.
     
  3. Beermonster

    Beermonster Member

    I've done that and still the same, is there a way to stop it wanting to upgrade while this is fixed?
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Try downloading the .zip package again from your customer area.
    The one you have may be corrupt.
     
  5. Beermonster

    Beermonster Member

    I did that before I re-uploaded it
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    The only times I have seen this it has been due to file corruption, either from the original .zip or during the upload.

    If you open a ticket and provide FTP and ACP access I can take a look.
     
  7. Beermonster

    Beermonster Member

    Will do, thanks
     

Share This Page