[XFA] Custom Username Icons - XF2

[XFA] Custom Username Icons - XF2 [Paid] 5.0.7

No permission to buy (€10.00)

XFA

Well-known member
XFA submitted a new resource:

Custom Username Icons - All username, usergroup and usertitle customization your members ever dreamed of !

Description
Custom Username Icons brings a new level of customization for you and your users !

This add-on lets your user select an icon to be displayed near their username everywhere on your board.
Icons can be selected either from a list of Font Awesome icons (more than 500 icons) or from a list of images icons of your choice.

Total control is given through the admincp to fine tune and manage the functionnality:
  • Permission to select an icon and configure it can be...

Read more about this resource...
 

XFA

Well-known member
XFA updated [XFA] Custom Username Icons with a new update entry:

Maintenance version

Corrected bugs:
  • Template public:forum_list: Declaration of XFA\CustomUsernameIcons\XF\Repository\Thread::findThreadsForForumView(XF\Entity\Forum $forum, $visibilityLimit = true) should be compatible with XF\Repository\Thread::findThreadsForForumView(XF\Entity\Forum $forum, array $limits = Array) (src/addons/XFA/CustomUsernameIcons/XF/Repository/Thread.php:41)

Read the rest of this update entry...
 

[xFv]

Well-known member
Is it possible for you to make it so when a avatar icon is used, let it also show in the widgets like new posts, new threads, including on a home page?
 

XFA

Well-known member
Is it possible for you to make it so when a avatar icon is used, let it also show in the widgets like new posts, new threads, including on a home page?

That's already done :)
Or did you experience it not working ?
 

[xFv]

Well-known member
That's already done :)
Or did you experience it not working ?

I should have been more clear... The image that replaces the avatar image in the widgets.
It works for the avatars great, but dont pull in the replacement.
 

XFA

Well-known member
I should have been more clear... The image that replaces the avatar image in the widgets.
It works for the avatars great, but dont pull in the replacement.

?! Don't get it, what is the link with my add-on ?
 

Jean-Baptiste

Well-known member
Hello @XFA,

I have a lot of bugs in your addon.

1) First, none thread is viewable.
Error Stack :
To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.
Quick fix :
Line 143 of the XF/Templater.php, add && $user check in the if condition.

2) Template error on threads
Template errors
  • Template public:message_macros: Creating default object from empty value (src/addons/XFA/CustomUsernameIcons/XF/Template/Templater.php:155)
  • Template public:message_macros: Creating default object from empty value (src/addons/XFA/CustomUsernameIcons/XF/Template/Templater.php:155)
Quickfix :
Line 152 add :
if( !$user ) {
$user = \XF::visitor();
}
3) The URI to the XFA username image is invalid, example : https://boardid/threads/557071/data/xfa/customusernameicons/icons/star.png

Thanks for your quickfix.
 

Jean-Baptiste

Well-known member
New bug :

When a user select an icon, then delete it, it's showing up a broken image.

Have you tested this addon before releasing it ?
 

XFA

Well-known member
Hello @XFA,

I have a lot of bugs in your addon.

1) First, none thread is viewable.
Error Stack :
To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.
Quick fix :
Line 143 of the XF/Templater.php, add && $user check in the if condition.

2) Template error on threads
Template errors
  • Template public:message_macros: Creating default object from empty value (src/addons/XFA/CustomUsernameIcons/XF/Template/Templater.php:155)
  • Template public:message_macros: Creating default object from empty value (src/addons/XFA/CustomUsernameIcons/XF/Template/Templater.php:155)
Quickfix :
Line 152 add :
if( !$user ) {
$user = \XF::visitor();
}
3) The URI to the XFA username image is invalid, example : https://boardid/threads/557071/data/xfa/customusernameicons/icons/star.png

Thanks for your quickfix.

1) & 2)

Is that when anonymous post ?

New bug :

When a user select an icon, then delete it, it's showing up a broken image.

Have you tested this addon before releasing it ?

Yes I tested it but maybe not all use cases.
It's when selected an image icon ?

Btw, if you want faster support, use our forum instead we don't connect everyday here.
 

Jean-Baptiste

Well-known member
1) & 2)

Is that when anonymous post ?



Yes I tested it but maybe not all use cases.
It's when selected an image icon ?

Btw, if you want faster support, use our forum instead we don't connect everyday here.

No, it wasn't an anonymous post.
For the 3), yes, it is when a user select an icon.
 

XFA

Well-known member
XFA updated [XFA] Custom Username Icons - XF2 with a new update entry:

Maintenance release

Corrected bugs:
  • TypeError: Argument 2 passed to XF\Mvc\Entity\Manager::instantiateEntity() must be of type array, null given, called in /public_html/src/addons/XFA/CustomUsernameIcons/XF/Template/Templater.php on line 148
  • Template public:message_macros: Creating default object from empty value (src/addons/XFA/CustomUsernameIcons/XF/Template/Templater.php:155)
  • Preview of server icons not working in account details page
  • Invalid image url for server icons
  • Icon still...

Read the rest of this update entry...
 
Top