XF 2.0 xf_ip_match Missing

SandyF

Member
Hi, I'm running an upgrade and ran into this error - I can't seem to even go backward from this so my boards are shut until I get it fixed.

Can I just create this table?


Full error;
InvalidArgumentException: Table 'xf_ip_match' does not exist so cannot be altered in src/XF/Db/Schema/Alter.php at line 38
  1. XF\Db\Schema\Alter->__construct() in src/XF/Db/SchemaManager.php at line 188
  2. XF\Db\SchemaManager->newAlter() in src/XF/Db/SchemaManager.php at line 141
  3. XF\Db\SchemaManager->alterTable() in src/XF/Install/Upgrade/2000010-200a.php at line 818
  4. XF\Install\Upgrade\Version2000010->step9() in src/XF/Install/Controller/Upgrade.php at line 169
  5. XF\Install\Controller\Upgrade->actionRun() in src/XF/Mvc/Dispatcher.php at line 249
  6. XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 89
  7. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 41
  8. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 1880
  9. XF\App->run() in src/XF.php at line 328
  10. XF::runApp() in install/index.php at line 14

Thanks!
 

SandyF

Member
So, lacking further advice, I created a temp directory and did a full install of 2.0.1 but now I'm stuck at importing data. I have a backup of my existing database but the importer in 2.0.1 only offers me import from 2.0 beta and no option for importing external data like it says to do in the instructions.

Help?

Thanks!
 

Chris D

XenForo developer
Staff member
The XF 2.0 importer covers the entire 2.0.x range. The (Beta) label refers to the status of the importer - it hasn't received enough real world testing yet to verify it is bug free.

However, I'd suggest forgetting the idea of the import, not least because you'll be importing from a partially upgraded XF 2.0 database so it likely won't work.

Just run this query to get past the missing table error:
SQL:
CREATE TABLE `xf_ip_match` (
  `ip` varchar(43) NOT NULL,
  `match_type` enum('banned','discouraged') NOT NULL DEFAULT 'banned',
  `first_byte` binary(1) NOT NULL,
  `start_range` varbinary(16) NOT NULL,
  `end_range` varbinary(16) NOT NULL,
  `create_user_id` int(10) unsigned NOT NULL DEFAULT 0,
  `create_date` int(10) unsigned NOT NULL DEFAULT 0,
  `reason` varchar(255) NOT NULL DEFAULT '',
  `last_triggered_date` int(10) unsigned NOT NULL DEFAULT 0,
  PRIMARY KEY (`ip`,`match_type`),
  KEY `start_range` (`start_range`),
  KEY `create_date` (`create_date`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;
However, which version of XF are you upgrading from?
 

SandyF

Member
I think 1.5.0 that's the last zipped package I see in my folders.


Ran the query but now I'm a little gun shy about attempting the upgrade again...
 
Last edited:

Chris D

XenForo developer
Staff member
Restoring wouldn’t really have been necessary, the upgrade should have been able to continue.

But yeah, just start the upgrade again and I’m sure it will be fine.
 
Top