• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF on Apache PHP version 5.6.5 Could not open socket

farang

Well-known member
#1
Switching from Apache PHP version 5.5.21 to 5.6.5 causes server log entries:

Code:
Server Error Logs
Server Error Logs
Email to X@Outlook.com failed: Could not open socket 6 minuter sedan - library/Zend/Mail/Protocol/Abstract.php:277
cannot connect to host; error = (errno = 0 ) 8 minuter sedan - library/Zend/Mail/Protocol/Pop3.php:109
cannot connect to host; error = (errno = 0 ) igår kl 18:29 - library/Zend/Mail/Protocol/Pop3.php:109
Email to X@hotmail.com failed: Could not open socket igår kl 18:18 - library/Zend/Mail/Protocol/Abstract.php:277
(E-mail addresses above altered)

Switching back to PHP version 5.5.21 makes the errors to stop.
 

Mike

XenForo developer
Staff member
#2
These are issues with your underlying network connection rather than something XenForo has any control over. It may be related to a firewall blocking the connection from even being opened, for example. It may also be an underlying change in PHP (especially if you are using secure connections, as there are changes in 5.6 relating to that).

You may need to contact your host for them to investigate.
 

farang

Well-known member
#3
These are issues with your underlying network connection rather than something XenForo has any control over
Great, nothing to worry about then. I stay on the old PHP version. Thanks. It's just as simple as selecting a value in a drop down box at my host. If they have a misconfigured server they will probably be aware about it sooner or later.